! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
keyboard shortcut for "maximize windows" doesn't work after reboot


Description squalou.jenkins 2011-01-08 14:51:05 CET
I'm using Archlinux, which provides version 4.6.2 of Xfwm4,
so I apologize if this is no more relevant.

What happens : I bind the keyboard shortcut "super m" to the maximize function.
It works juste fine.

If I reboot (or leave the session), next time the shortcut won't work.

In the configuration panel, the shortcut appears as if correctly set, but it is not working.

Other shortcut work fine.
I tried another key cmbination : same problem.
I tried the "super m" for another shortcut : it works.

So it narrows the issue to the "maximizeé thing.

Thank you,

Comment 1 Olivier Fourdan editbugs 2011-01-08 15:01:36 CET
Humm, works just fine here.

"Super" is a bit special with some keyboard mappings and is reported as both a modifier and a regular key,  I guess this is the source of your problem.

I don't think it's a bug in xfwm4 (as I said, works just fine here, Fedora 13)
Comment 2 squalou.jenkins 2011-01-08 21:07:41 CET
(In reply to comment #1)
> Humm, works just fine here.
> "Super" is a bit special with some keyboard mappings and is reported as both a
> modifier and a regular key,  I guess this is the source of your problem.
> I don't think it's a bug in xfwm4 (as I said, works just fine here, Fedora 13)

I've got the "super" key mapped to other shortcut, (super v for vertical maximize e.g. ) : it works fine.
If I use this working hortcut for maximise : this one does not work.

That's why I'd say it points to "maximize" issue.

Next time I login, I'll try Alt instead of Super, I'm pretty sure I already did that but I prefer try again.
Comment 3 squalou.jenkins 2011-01-09 11:35:29 CET
I just tried with "Alt M" shortcut : same result.
After reboot, the shortcut doesn't work anymore, even if it appears as associated in the conf panel.

This confirms that - at least in my case, who knows why - the "maximize" thing get disassociated after reboot, or is not correctl associated at start.
Comment 4 Olivier Fourdan editbugs 2011-01-09 11:47:02 CET
Yet there is nothing particular to the maximize shortcut, it's just one of the shortcuts like the others.

What gives "xfconf-query -c xfce4-keyboard-shortcuts -lv" beffore and after the reboot?

There is also a known issue with shortcuts being lost (see bug 5537).
Comment 5 squalou.jenkins 2011-01-09 15:12:05 CET
Created attachment 3331 
xfconf-query -c xfce4-keyboard-shortcuts -lv
Comment 6 squalou.jenkins 2011-01-09 15:12:35 CET
The command gives the exact same result before and after reboot.
(I used diff to be sure)

The "interesting" line might be :
/xfwm4/custom/<Super>m                     maximize_window_key

Fun thing : I also have this line
/xfwm4/default/<Alt>F10                    maximize_window_key

But Alt F10 does not work either.
Comment 7 Stephen Warren 2013-02-06 07:24:28 CET
Bug 4875 reports basically the exact same issue. It is marked as a duplicated of bug 4695. Should this bug be marked as a duplicate too?

However, bug 4695 is more about the handling of multiple entries in the keyboard shortcut config files with the same logical function not being ideal. This bug and I think 4875 are more about the fact that xfce is creating a keyboard shortcut file with duplicate entries in the first place. Hence, I'm not sure if the duplicate marking is entirely correct.

For additional details, please see:

There I observe that xfce itself is creating this issue (it creates a config file with both ALT-F7 and ALT-F10 pointing at maximize_window_key; no user editing of the config file or use of xfconf is needed to cause this issue). Quoting from that bug:

Strange. I believe the file /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml is the default content for .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml, and should be copied to it when "Reset to defaults" is executed in the XFCE settings application.

However, /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml does NOT contain entries for both ALT-F7 and ALT-F10 being set to maximize_window_key (it just has an entry for ALT-F10), yet "Reset to defaults" DOES recreate this issue in the user's .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml. It seems like something in the application code rather than the default settings file is causing this problem.
Comment 8 geoffm 2013-12-14 17:42:33 CET
*** Bug 10537 has been marked as a duplicate of this bug. ***
Comment 9 geoffm 2013-12-14 17:45:21 CET
Same problem here, running Xubuntu 13.10.
It's been reported for almost a year, hopefully we can have some follow up?
We have to open the settings to remap the shortcut every time we reboot.
Surely there aren't only 3 people in the world who remap this shortcut?
Comment 10 Simon Steinbeiss editbugs 2015-02-05 00:36:31 CET
*** Bug 10952 has been marked as a duplicate of this bug. ***
Comment 11 Simon Steinbeiss editbugs 2015-02-05 00:37:21 CET
*** Bug 10959 has been marked as a duplicate of this bug. ***
Comment 12 Olivier Fourdan editbugs 2015-02-05 22:11:29 CET
Still cannot reproduce.

What keyboard layout do you use?
Comment 13 Strider 2015-02-13 13:54:24 CET
I have the same ussie. I'm using Alt + Enter to maximize. It works until reboot. In next run shortcut is erased. Happens only with maximize function as for topicstarter.

It happens in "us" keyboard layout. I have quite standard system with standard package sources. Bug is stable reproducible.

↳ xfwm4 --version
	This is xfwm4 version 4.11.1 (revision 2b800f4) for Xfce 4.10
	Released under the terms of the GNU General Public License.
	Compiled against GTK+-2.24.23, using GTK+-2.24.23.

	Build configuration and supported features:
	- Startup notification support:                 Yes
	- XSync support:                                Yes
	- Render support:                               Yes
	- Xrandr support:                               Yes
	- Embedded compositor:                          Yes
	- KDE systray proxy (deprecated):               No

↳ lsb_release --all 
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.1 LTS
Release:	14.04
Codename:	trusty

↳ uname --all
Linux aperture 3.13.0-45-generic #74-Ubuntu SMP Tue Jan 13 19:36:28 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Comment 14 Olivier Fourdan editbugs 2015-02-13 14:55:49 CET
Can you please attach the full content of your "~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml" ?
Comment 15 Olivier Fourdan editbugs 2015-02-13 15:03:16 CET
(In reply to Olivier Fourdan from comment #14)
> Can you please attach the full content of your
> "~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml" ?

Even better, Set the shortcut, save "~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml", then reboot, then copy "~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml" again and attach them both (before/after) here.
Comment 16 Strider 2015-02-21 22:48:09 CET
@Olivier Fourdan
It semees issue is fixed. I've looked through config you noted and it has two binding for maximize: `Alt + Enter` and `Alt + F10`. Don't know how it happened, as I do not use any custom utilities rather then Xfce supplies. I've just delete `Alt + F10` binding and everything works fine instantly and after reboot, so now binding is stable.

Bug #7070

Reported by:
Reported on: 2011-01-08
Last modified on: 2020-05-26
Duplicates (3):
  • 10537 Maximize keyboard shortcut not remembered after reboot
  • 10952 Key combinations tends to broke
  • 10959 Maximize Window shortcut is not persisted


Olivier Fourdan
CC List:
6 users



xfconf-query -c xfce4-keyboard-shortcuts -lv (8.32 KB, text/plain)
2011-01-09 15:12 CET , squalou.jenkins
no flags

Additional information