! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Fails to load when the previous video is missing
Very High


Description TioTrom 2020-04-09 17:45:06 CEST
Say you open a  video with Parole. Then you close the video and delete the video from your computer. Now you want to open another video with parole.

Such as: 

** (parole:98364): WARNING **: 17:43:52.139: Unable to read file info Error when getting information for file “/home/tio/Downloads/Trade-Free.mp4”: No such file or directory
Segmentation fault (core dumped)
Comment 1 TioTrom 2020-04-27 18:27:18 CEST
So basically Parole does not start anymore if it does not find the previous video. No error, nothing. Users may get confused as to why it doesn't start again.
Comment 2 Simon Steinbeiss editbugs 2020-04-28 01:13:19 CEST
Very strange, I can't reproduce this behavior at all.

Which distribution and version of Parole are you using and did you change any of its settings?
Comment 3 TioTrom 2020-04-28 20:32:59 CEST
Ok I narrowed it down now, Check the option "remember playlist" and then try the above. Seems that is breaking it.
Comment 4 Simon Steinbeiss editbugs 2020-04-28 23:43:33 CEST
I still cannot reproduce... Parole complains that the file isn't there anymore but it starts normally.

With autoplay enabled it throws a gstreamer error about not finding the file. Without autoplay the item remains in the playlist...
Comment 5 TioTrom 2020-04-28 23:51:34 CEST
Ok so I can replicate it here every time. I am using Manjaro + Gnome. Maybe in Gnome it fails to display the error message and that's why it fails to start?
Comment 6 Simon Steinbeiss editbugs 2020-04-29 00:09:42 CEST
The error message comes from gstreamer directly (I think, haven't dug up the code), not parole.
Comment 7 TioTrom 2020-04-29 23:14:36 CEST
Did you test in on a Gnome desktop?
Comment 8 brzoska.jerzy 2020-05-11 09:28:15 CEST
Yesterday I tried to launch parole, it would start. This is what I get from the terminal:
jerzy@jerzy-pc:~$ parole

** (parole:9968): WARNING **: 09:05:46.320: Unable to read file info Error when getting information for file “/home/jerzy/pCloudDrive/Computer Science/Courses/CS50.harvard.edu/HARCS50T2017-V000100_DTH.mp4”: No such file or directory

** (parole:9968): WARNING **: 09:05:46.321: Unable to read file info Error when getting information for file “/home/jerzy/pCloudDrive/Computer Science/Courses/CS50.harvard.edu/week1/HarvardXCS50-V000500_DTH.mp4”: No such file or directory
Segmentation fault

My solution (I read about it here https://bugzilla.xfce.org/show_bug.cgi?id=14175) :

jerzy@jerzy-pc:~/.local/share/xfce4/parole$ sudo rm auto-saved-playlist.m3u 

Removing this playlist solved this issue. All is well now.
Comment 9 Git Bot editbugs 2020-05-24 01:48:33 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/apps/parole/-/issues/59.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #16658

Reported by:
Reported on: 2020-04-09
Last modified on: 2020-05-24


Simon Steinbeiss
CC List:
3 users



Additional information