! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Scrollbar doesn't work when window is maximized and mouse is hugging right si...


Description jazztickets 2019-09-01 19:54:51 CEST
Created attachment 8975 

In Qt programs like Cantata or VLC, when you maximize the program and try scrolling on the very right edge of the screen, the scrollbar doesn't register.


1. Load up Cantata and maximize the window.
2. Add enough music to the playlist so that scrollbars appear.
3. Move your mouse as far right as it can go.
4. Click the scrollbar  "thumb" and drag down.
5. Notice how no scrolling occurs.

This also happens in VLC. However, it does not happen in QtCreator for whatever reason. It does not happen in KDE or Gnome.
Comment 1 Olivier Fourdan editbugs 2019-09-02 09:26:44 CEST
Can you please post the output of :

$ xfconf-query -c xfwm4 -vl
Comment 2 jazztickets 2019-09-02 16:07:06 CEST
Created attachment 8984 
output of 'xfconf-query -c xfwm4 -vl'

output of 'xfconf-query -c xfwm4 -vl'
Comment 3 Olivier Fourdan editbugs 2019-09-02 17:11:19 CEST
I tried with VLC or kinsole and was able to reproduce. However, I tried with mutter as well and it was the same so this is not an xfwm4 specific issue.

The same works with other apps (GTK+ or Google Chrome for example) so I reckon this is a toolkit issue, not sure why comment 0 states that the same works in KDE or GNOME, it certainly does not work in GNOME either, at least here.

Maybe a theme issue?
Comment 4 jazztickets 2019-09-03 01:59:48 CEST
The GNOME comment was from this ( https://github.com/CDrummond/cantata/issues/1474#issuecomment-482926419 ), so I didn't actually test it. Although I just tested it in virtualbox and I get the same problem as xfce like you said.

It's weird, I just tested Geany (gtk3) in xfce and it fails to scroll, but it works in KDE Plasma.

All the xfce themes I tested exhibit the same behavior. For reference i'm using Greybird on Arch Linux.
Comment 5 alexxcons editbugs 2019-10-17 08:58:00 CEST
Same bug exists for thunar and mousepad:

Bug #16050 and Bug #16056

Fixed for thunar by setting some "border-right-width" to zero.

My guess would be that this bug needs to get fixed per application, and we can close this one.
Comment 6 jazztickets 2019-10-17 16:27:41 CEST
"border-right-width" is a GTK property, right?  There might be two issues then. One with GTK and another with Qt. But for some reason KDE Plasma is handling it correctly (or perhaps just differently such that it works, maybe as a workaround).
Comment 7 Git Bot editbugs 2020-05-29 12:29:35 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/xfce/xfwm4/-/issues/346.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #15911

Reported by:
Reported on: 2019-09-01
Last modified on: 2020-05-29


Olivier Fourdan
CC List:
1 user




gif (27.08 KB, image/gif)
2019-09-01 19:54 CEST , jazztickets
no flags
output of 'xfconf-query -c xfwm4 -vl' (3.60 KB, text/plain)
2019-09-02 16:07 CEST , jazztickets
no flags

Additional information