! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
moving titlebar buttons makes them disappear from settings UI


Description Aurélien Murith 2019-07-21 07:53:40 CEST
Switching a titlebar button's position works fine, but once you have moved it, it disappears from the settings interface, so you cannot move it anymore unless you close and reopen the settings panel.
Comment 1 Olivier Fourdan editbugs 2019-07-21 09:59:32 CEST
Works fine here, please provide the reproduction steps.
Comment 2 Aurélien Murith 2019-07-21 12:55:23 CEST
Nothing special to do: open the settings panel -> window manager, move titlebar buttons and you will see them disappear (from settings interface, not from titlebar). If you move all of them there will be at the end no single button anymore.

This is a Xfce 4.13 problem, in 4.12 it works fine.
Comment 3 Theo Linkspfeifer editbugs 2019-07-22 12:49:14 CEST
I cannot reproduce this bug either.

Are you sure that you have version 4.13.2? It includes the fix for bug 14606.
Comment 4 Aurélien Murith 2019-07-23 17:21:30 CEST
For sure, I'm currently running xfwm 4.13.2 on Mageia 7. I also tried on Fedora (which has 4.13.3) and got the same result.
Comment 5 oren.barnea 2019-07-25 07:55:43 CEST
Created attachment 8811 
Disapparing buttons

Reproduction of the bug on Xubuntu 19.04 with Xfce testing repository enabled
Comment 6 waylonpeng 2019-08-20 06:40:44 CEST
I can reproduce this bug, Xfce 4.14 on Manjaro Linux 18.0.4. Behavior is identical to the video attached earlier.
Comment 7 Theo Linkspfeifer editbugs 2019-08-20 11:13:28 CEST
After checking again I can confirm that the bug occurs when xfwm4-settings is embedded in the Settings Manager.
Comment 8 Remi 2019-09-19 18:39:01 CEST
I have the same issue with xfwm4-settings 4.14.0 when launched from xfce4-settings-manager 4.14.1 on Fedora 30.

Seems to be a duplicate of https://bugzilla.xfce.org/show_bug.cgi?id=13861
Comment 9 Theo Linkspfeifer editbugs 2020-01-20 18:12:19 CET
*** Bug 16396 has been marked as a duplicate of this bug. ***
Comment 10 Theo Linkspfeifer editbugs 2020-04-02 12:07:40 CEST

*** This bug has been marked as a duplicate of bug 13861 ***

Bug #15733

Reported by:
Aurélien Murith
Reported on: 2019-07-21
Last modified on: 2020-04-02
Duplicates (1):


Olivier Fourdan
CC List:
6 users




Disapparing buttons (872.08 KB, video/mp4)
2019-07-25 07:55 CEST , oren.barnea
no flags

Additional information