! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Segmentation fault running Thunar as root with pkexec


Description Paul 2018-06-26 14:27:21 CEST
On upgrade to 1.8.0 I can no longer run thunar as root with the following commands:

pkexec dbus-launch thunar /
pkexec thunar /

Thunar opens about half the time.  In any case as soon as I try to enter a new directory it crashes with a segmentation fault:

    [x@xlaptop ~]$ pkexec dbus-launch thunar /

    *[DOUBLECLICK /etc]*
    (thunar:2096): GLib-GObject-CRITICAL **: 14:16:22.440: g_object_get_data: assertion 'G_IS_OBJECT (object)' failed
    (thunar:2096): Gtk-WARNING **: 14:16:22.440: gtktreemodel.c:2495: bad row reference, proxy has no outstanding row references
    Segmentation fault (core dumped)

I have downgraded to version 1.6.15 for now.

Incidentally the UI also changed for the worse in my opinion.  It looks like you changed to bold fonts.  This creates much more line-spacing and means I can now fit/see much less on screen than before.

Arch Linux
Comment 1 alexxcons editbugs 2018-06-26 21:53:34 CEST
Cannot reproduce because pkexec refuses to work for me. Basically same as here:  https://bbs.archlinux.org/viewtopic.php?id=127716
No matter if I use "pkexec dbus-launch thunar" or "pkexec thunar".

Any idea ? Do I need to have some special setup to get that to work?

sudo thunar works fine for me by the way

Maybe pkexec does not like gtk3 that much ? What about other gtk3 applications launched via pkexec ?  Do they work fine ?
Comment 2 Andre Miranda editbugs 2018-06-27 04:28:36 CEST
pkexec thunar works fine here (Arch Linux too), tried many times no errors.

pkexec dbus-launch thunar fails with:
Unable to init server: Could not connect: Connection refused
(thunar:2058): Gtk-WARNING **: 23:20:49.810: cannot open display:

Can you provide the full backtrace?

With regards the visual changes, most of them were introduced by gtk3 itself, not our doing :)
Some of those change are to be tweaked by the theme, as far as I'm aware Greybird is the only theme ready for Thunar 1.8.0.
Of course, we are open to improvements, for instance Bug #14459. So please file another bug for the visual adjustments you see fit.
Comment 3 Paul 2018-06-29 10:33:24 CEST
How can I get a full backtrace?
Comment 4 Andre Miranda editbugs 2018-06-30 14:57:14 CEST
(In reply to Paul from comment #3)
> How can I get a full backtrace?

Basically just run "gdb thunar", but it's not very helpful because thunar from Arch repository doesn't contain debug symbols. You can help us a lot more if you are able to build thunar and get the backtrace from it, the steps are:

git clone git://git.xfce.org/xfce/thunar
cd thunar
./autogen.sh --prefix=/usr --enable-debug=yes
pkill -i thunar
gdb thunar/.libs/thunar

gdb will start, then press 'r' and 'enter'
thunar will start, when it crashes, press 'bt' and 'enter'
this will generate the full backtrace that you can copy and attach to this bug.
Comment 5 Andre Miranda editbugs 2018-07-06 03:53:44 CEST
@Paul, I just learned that there's an easier way to get the backtrace (actually the whole coredump), you won't even need to build Thunar.
Make sure to crash Thunar again and run coredumpctl list, check if there is a new entry for thunar and pay attention to its PID. Then run coredumpctl dump <PID> -o ~/thunar.core. Zip that file and send us.
Comment 6 alexxcons editbugs 2019-01-16 23:01:09 CET
@Paul, you are still with us ?  Does the crash still happen for you? You tried to get the coredump ?
Comment 7 Git Bot editbugs 2020-05-26 23:36:52 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/xfce/thunar/-/issues/204.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #14476

Reported by:
Reported on: 2018-06-26
Last modified on: 2020-05-26


Xfce Bug Triage
CC List:
4 users



Additional information