! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
xfce4-session-logout latency


Description jppande 2013-03-07 20:48:32 CET
when clicked on Logout option from applications menu or xfce4-session-logout from commandline, the logout dialog appears very late (after ~2mins).
a message (xfce4-session:CRITICAL dbus_set_g_error could not verify == NULL(not exact msg) ) is displayed at ctrl+alt+F1

Problem arises for users:         normal user and root as well
OS:                               LFS 
dbus, consolekit installed, working well.
Comment 1 kaurman 2013-11-02 22:43:25 CET
Any news on that one? I've been experiencing something very similar for quite a while. Running xfce 4.10 on arch. Everything else seems to work ok but the logout dialog takes ages to appear and the rest of the system is somewhat slow to respond until it does. 

True, *the dialog appears fine if to switch to another runlevel and back after clicking the 'logout' button*. 

Any ideas on how to find out if it actually is (an xfce) bug in the first place?

PS /var/run/ and /var/lock/ are symlinks as they should be in the case of arch (some have reported similar issues when they are not).
Comment 2 MS 2013-11-20 17:29:13 CET
Hi, same issue for me. When hitting the logout button in the menu or running xfce4-session-logout from a terminal Xorg CPU usage goes up till nearly 100%. System is very slow and logout dialog takes 2 - 5 min to be displayed.

However, I can also confirm that switching to another terminal resolves the issue. Dialog is displayed immediatly after switching back.

Running "xfce4-session-logout -l" works fine. Disabling Setting --> Session and Startup --> "Ask before logout" resolves the issue too. Looks like a problem with the GUI to me.
Comment 3 kaurman 2013-11-20 19:09:12 CET
I have some good news. I discovered a few days ago that the bug is gone for me.
The bad news is that I have no idea what 'fixed' it since I have made quite a few changes during the past few days. The biggest was getting the proprietary ati driver instead of the open alternative but I seriously doubt this has anything to do with the bug. One of the things I messed with as well was the theme of my desktop (theme as such + icons).

I'll try and see if I can reverse the changes I've made and will report should I find something. As for the theme & icons, this doesn't seem to be the thing but you may try just in case.

I'm not sure whether cpu usage was high when I suffered from the bug. I should have noticed but who knows.
Comment 4 MS 2013-11-20 19:43:36 CET
I'll give the proprietary driver a try. Or at least make a testrun with the default vesa driver.
Comment 5 MS 2013-11-20 20:44:57 CET
Ok, looks like the radeon driver is part of the problem. Started my arch with kernel parameter "xforcevesa" and tried to log out    ... no problem.
Comment 6 kaurman 2013-11-20 21:40:44 CET
You don't say... I didn't consider it too likely. Still, glad to hear. I think you should file a bug report against the driver then. If you do, be sure to share the link. It'd be interesting to observe.

True, we can't still be 100% sure that the radeon driver is to blame. It may be, as you said, 'part of the problem'. Still, based on the above comments we have considerable grounds for being suspicious about the driver so I think reporting can't hurt. At worst they'll just make us find out that the driver isn't to blame after all.
Comment 7 MS 2013-11-20 22:37:00 CET
True, true. Nevertheless, I still consider the xfce team responsible for the bug. Shurely they can give a much more specific description to the xorg team  than I can. 

Let's wait what they have to say ...
Comment 8 MS 2014-01-23 15:57:21 CET
Just found out there allready is a bug reported against the driver :


Seems to be an issue with the glamor rendering. They suggest to force EXA instead via

Option      "AccelMethod"           "EXA"

in your xorg.conf "Device" Section.
Comment 9 kaurman 2014-01-23 17:25:54 CET
(In reply to MS from comment #8)
> Seems to be an issue with the glamor rendering. They suggest to force EXA
> instead via
> Option      "AccelMethod"           "EXA"
> in your xorg.conf "Device" Section.

Thanks for the info. Works like a charm. (I decided to abandon the proprietary driver after another X version issue.)
Comment 10 MS 2014-01-24 13:18:45 CET
Tested for 2 days now. Works for me ,too. I suggest to close this bug as it is related to the driver.
Comment 11 Eric Koegel editbugs 2014-11-05 17:23:07 CET
Marking bug as closed per last comment. Please reopen this report if you can still reproduce it.
Comment 12 europe66168 2015-08-19 13:09:04 CEST
Related to the driver ? 
Xfce team had fixed it for xubuntu 15.04, why not for xubuntu 14.04 ?

Bug #9897

Reported by:
Reported on: 2013-03-07
Last modified on: 2015-08-19


Xfce Bug Triage
CC List:
6 users




Additional information