! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Incomplete copy or move of single or last file


Description Bart 2012-11-02 21:52:24 CET
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build Identifier: Thunar 1.4.0

When I copy or move one file or multiple files then the single file or the last of the multiple files gets not copied in full when the files are over a couple of MB or so (I can't determine when it starts going wrong). The file is corrupt and the size is too small.
It doesn't seem to happen when I copy or move folders.
To get the file correctly copied I copy it another time (replace it) and now the file is correct.

I use Xubuntu 12.10 x86-64 (but the bug was in 12.04 already).

Reproducible: Sometimes

Steps to Reproduce:
1. Select one or several files that are larger than 100 MB (to be sure) and keep the size of the files in mind.
2. Move or copy them to another folder (preferably another drive).
3. Compare file size of the last file copied or moved.
Actual Results:  
The file size of the last copied file is not correct and the file is corrupted.

Expected Results:  
I expected the file to be moved or copied correctly.

It should have copied or moved the file in its entirety.
Comment 1 Nemo Inis 2014-07-03 19:19:20 CEST
I think this may just be a refresh bug, not an actual corruption bug. Thunar does not properly display the final size of the last (or only) file copied from one disk to another if that file was very large.  Navigating to another directory then back to the target directory usually makes the correct size appear.

Original Poster: can you try this:

-after a "failed" copy, navigate Thunar away from the target directory (e.g. click on your home or anywhere else), then back to the target directory. Does the correct size appear now?

-Also: open a terminal in the source directory where the large file is, and type:
md5sum "name of large file"

-Then do the same in the target directory, and compare the md5 checksums. Do they match?
Comment 2 Bart 2014-07-04 05:23:33 CEST
I'm the OP, now working with Thunar 1.6.3. The problem is still there, on other computers as well.

I remember this problem came to light after having created a torrent for which I copied a large file. The recipient said it was corrupt so I checked and it didn't work on my computer as well. Only then I noticed the file-size was wrong. I copied it again, using the overwrite-option and then the right file-size showed up and the file was okay. I did some minor testing and after that I reported this problem.

After a while I tested if these ill-sized files were actually corrupted and did the hash-test myself already. It turned out the files were all actually okay, so eventually the problem with the file I created a torrent of was corrupted for another reason. I can't tell what may have caused that. So as you say, Nemo Inis, it may very well be some kind of a refresh-bug.

Still reloading the directory doesn't make a difference, neither does navigating out of the directory and return or closing down that particular pane and opening it, or navigating to it from within another already opened pane. Then the file-size remains wrong. The file-size in the properties pane shows the wrong size as well, just as the properties pane from the folder the file is located in, which makes it hard to compare directories.

What does make a difference is closing down ALL panes of Thunar and then open the directory again. Then the file-size shows up correctly.
Also other file-managers show the file-size correctly while having the destination open during the Thunar copy-operation, while Thunar is showing the wrong size. When I copy a file from within another file-manager and have the destination directory open in Thunar, the file-size always seems to be instantly correct.

Thunar is a lightweight manager, starts in an instant and is versatile. But for larger or multiple file-operations I prefer to open other more sluggish software, or I have to copy the file(s) twice with Thunar, or have to close Thunar and open both (origin and destination) directories another time to check if nothing went wrong. So it's still annoying not to be able to see in an instance if a large copy-operation went okay. I still hope this problem can be looked into and somehow get solved. 

Comment 3 Raphael Groner 2014-11-21 02:19:48 CET
I can confirm that Thunar does not refresh $everything when the user clicks on Refresh. For instance, a chmod from terminal is not detected, only if the folder gets reopened: That folder stays to be read-only though chmod +w from terminal and click on Refresh in Thunar.
Comment 4 Raphael Groner 2014-11-21 02:20:13 CET
Comment 5 Harald Judt editbugs 2015-02-20 20:27:46 CET
This should be fixed in 1.6.5. Please reopen if not.
Comment 6 Bart 2015-02-20 21:14:35 CET
Thanks Harald. It would be great if this issue had been fixed. I can hardly wait to test it and hopefully report the good news.

I see 1.6.5 will be available on Xubuntu 15.04.

But can I install it (thunar_1.6.5-0ubuntu1_amd64.deb) on 14.* as well, or should I wait until 15.04 is released?
Comment 7 Bart 2015-02-21 17:59:16 CET
I did some testing and still found an issue, so I thought it would be better to reopen this bug report. 

I tried to install Thunar 1.6.5 on a 14.05 VMWare-image, but that didn't work out due to dependency issues. I created a Xubuntu 15.04 image (latest amd-64 daily build from http://cdimage.ubuntu.com/xubuntu/daily-live/current/) and tested moving and copying a couple of large files. Almost everything went well, but only when I used a folder in the side pane it didn't go entirely as expected.

When I say "okay" is that when I copy or move some files they immediately show up in the destination folder and the files/folders show up with the right sizes in the destination in Thunar without refreshing or any other trickery.

This doesn't go entirely well though when I use a folder in the tree view in the side pane, or a folder I added to "Places" in the Shortcuts view as destination.

When I either use select+drag/move with the mouse or "cut" + "paste into" options in the context-menu to move a couple of files (or a folder containing those files) from one folder into another folder in the side pane (which is also opened either tabbed or in a separate window), the files/folder do actually move, but they do not show up until I refresh the folder (the arrow in the address-bar or F5). Fortunately they then do have the right size.

This is the same if you open the destination folder in both another tab and another window, but if you refresh one pane the files immediately show up in both.

Also when I use cut form the side pane and paste it into another folder in the side pane I need to refresh the destination for the moved folder to show up.

When I select the files and drag/drop or cut+paste them directly into the large pane of another folder things go well, just as when I drag them, hover over another tab to get it focused and then drop them into the folder.

So to be short, the refresh error only occurs when files or a folder are moved (copying goes well) into or from a folder in the Side Pane.
Comment 8 Bart 2015-02-21 18:02:26 CET
And btw, I changed the version of the bug report to 1.6.5, because I don't think it will be fixed for older versions. It would be nice if that would still be possible for people working with older versions though.
Comment 9 Harald Judt editbugs 2015-04-17 20:06:49 CEST
Resolving duplicate.

*** This bug has been marked as a duplicate of bug 11008 ***

Bug #9446

Reported by:
Reported on: 2012-11-02
Last modified on: 2015-04-17


Jannis Pohlmann
CC List:
6 users



Additional information