! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
xfwm4 does not like rotated Xorg


Description sascha heid 2005-05-06 16:39:19 CEST
Im using Xorg rotated (pivot).
The result is that xfwm4 seems to try to counteract this.
I can scroll a little to the right (like a virtual desktop size) and a part of
the bottom is not available to my mouse-coursor.
Its like a 1280x1024 resolution on 1024x1280 screen.
All other WMs i tried (metacity, ion, ratpoison, pekwm, openbox) have no problem
with a rotated Xorg.

Reproducible: Always
Steps to Reproduce:
1. rotate X
2. restart X with xfwm4
3. move mouse around

I use Xorg's rotate, not NVidia's.
I tried Xorg 6.8.2 and cvs.
Comment 1 Olivier Fourdan editbugs 2005-05-08 21:49:36 CEST
I don't see anything in xfwm4 that would explain such behaviour. The WM doesn't
deal with the rotate AFAICT, it just deals with scree nsize and xfwm4 is working
fine with xrandr resize.

This said, I'm running Xorg 6.9.2 and I'm you to find the rotation, either from
NVidia or from nv driver, the only rotation I've ever seen is "normal". I'd like
to have a better description on how to reproduce the problem.

What if you run *only* the WM and a terminal (ie run a se called "failsafe"
session and launch "xfwm4" from the xterm), and play with xrandr, does it work?

Comment 2 Olivier Fourdan editbugs 2005-05-08 22:07:40 CEST
I just checked and I think your bug is invalid. I used the "Rotate" "CW" option
and xfwm4 works just fine.

I think you're being confused by the MCS "Display" setting that sets the xrandr
option on its own and thus probably breaks the CW/CCW rotate option, but that's
by no mean a bug in the window manager (at worst, it's a bug in Xorg because the
xrandr is said to be disabled with the rotate option in the "nv" man page)

Anyway, you can try this on your own, just log off, remove
$HOME/.config/xfce4/mcs_settings/display.xml and log in xfce again and you'll
see that the rotate options works just fine.
Comment 3 sascha heid 2005-05-09 07:16:07 CEST
You are right, its working fine now.

My mistake was to believe that commenting "Load "RANDR"" in xorg.conf would
disable it, which it does not. RANDR was still enabled and xfwm4 seems to load
something RANDR related when it starts and therefore the screen "broke".

Option "Randr" "0" solved it.

Sorry i wasted your time.

Bug #941

Reported by:
sascha heid
Reported on: 2005-05-06
Last modified on: 2009-07-14


Olivier Fourdan
CC List:
0 users



Additional information