! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Power Manager reports 0.0 readings for APC USB UPS


Description xfce 2012-10-02 16:49:48 CEST
I'm working with Lubuntu 12.04 which includes xfce4-power-manager 1.0.11.  That is with Lubuntu fully updated, so it does not know about the more recent releases (I believe 1.2 is current).

I am using an APC Back-UPS ES 350 (Model BE350U) connected via a simple signalling USB cable.  And although it is a simple signalling cable, on one test machine which has apcupsd installed, it reports smart-like information, much more than one would get with dumb voltage signalling.

But on one PC XFPM reports under Power Information: UPS:

Attribute - Value
--------    -----
Device - ups_hiddev0
Type - UPS
Power Supply - True
Energy full design - 0.0 Wh
Energy full - 0.0 Wh
Energy empty - 0.0 Wh
Voltage - 0.0 V

On another Lubuntu 12.04 PC - the one with apcupsd installed - XFPM reports:

Attribute - Value
--------    -----
Device - ups_hiddev0
Type - UPS
Power Supply - True
Model - 800.e5.D
Technology - Lead acid
Energy full design - 100.0 Wh
Energy full - 0.0 Wh
Energy empty - 0.0 Wh
Voltage - 0.0 V
Vendor - APC
Serial - AB0508340843

So it seems that XFPM is not communicating with whatever backend it uses for the UPS, or the backend is not monitoring effectively.

Needless to say, I have no confidence that XFPM will actually execute a graceful shutdown of the system in the event of a power outage.

Is this a known issue?  If it is, has it been fixed in the current release?  I don't know a thing about how XFPM works with its backend(s), but I know that apcupsd will accurately monitor this UPS.  Can XFPM be configured to use that as the backend?

Additional information: Apcupsd's "apcaccess status" command reports this about the same UPS:

APC      : 001,034,0853
DATE     : 2012-09-27 15:04:40 -0400  
HOSTNAME : lubuntu
VERSION  : 3.14.10 (13 September 2011) debian
UPSNAME  : lubuntu
CABLE    : USB Cable
UPSMODE  : Stand Alone
STARTTIME: 2012-09-27 13:37:49 -0400  
MODEL    : Back-UPS ES 350 
LINEV    : 122.0 Volts
LOADPCT  :   2.0 Percent Load Capacity
BCHARGE  : 100.0 Percent
TIMELEFT : 108.4 Minutes
MBATTCHG : 5 Percent
MINTIMEL : 3 Minutes
MAXTIME  : 300 Seconds
SENSE    : High
LOTRANS  : 088.0 Volts
HITRANS  : 138.0 Volts
ALARMDEL : No alarm
BATTV    : 13.5 Volts
LASTXFER : Low line voltage
TONBATT  : 0 seconds
CUMONBATT: 0 seconds
STATFLAG : 0x07000008 Status Flag
SERIALNO : AB0508340843  
BATTDATE : 2005-02-16
NOMINV   : 120 Volts
NOMBATTV :  12.0 Volts
FIRMWARE : 800.e5.D USB FW:e5
END APC  : 2012-09-27 15:04:44 -0400
Comment 1 Stephen Haffly 2012-10-16 21:26:52 CEST
Created attachment 4668 
screenshot of settings dialog
Comment 2 Stephen Haffly 2012-10-16 21:36:10 CEST
I believe that this is because xfce4-power-manager still depends on hal for functionality (at least according to the web page for the utility). However, hal has been deprecated since Fedora 16 and is no longer available. I did have it working, but it finally seems to have been broken when Fedora 17 did an upgrade to kernel 3.6.1 a few days ago.

I have been going around circles trying to get apcupsd running properly. It turns out also that for some reason, having a USB keyboard plugged in was interfering with being able to run apctest. It also seems to have been causing problems with apcupsd, but the error message had to do with "network thread busy," which did not make sense as I had tried several diffferent settings for the NISIP entry in apcupsd.conf.

Still, the problem here is not apcupsd's problems, but xfce4-power-manager's problems. I would appreciate it being fixed as it seemed to work quite well when it was running.

Linux emerald.hhome 3.6.1-1.fc17.x86_64 #1 SMP Wed Oct 10 12:13:05 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 xfce 2012-10-16 22:22:01 CEST
Though hal is available but not installed on Lubuntu, xfce4-power-manager Properties in Synaptic does not list any dependencies that seem to have any connection with hal.

So I wonder if that web page reference to hal dependence is obsolete.

If so, then the problem lies elsewhere.
Comment 4 Stephen Haffly 2012-11-01 02:23:21 CET
Updated kernel to 3.6.3-1.fc17.x86_64
Xfce 4.10 with all available current updates
xfce4-power-manager still only shows icon in notification area for plugged-in. It does not pop up the notification for UPS status, nor does it show the battery in the Power Information. In the preferences, there is still no way to see or change options for when the power is out and the UPS is supplying the power. It seems to not be able to get the status from the USB connection.

Meanwhile, apcupsd is working fine and gives the proper information. apctest works fine also.

On my netbook, it is a different story. It is running the same kernel and Xfce 4.10 version as the desktop, but the netbook's battery is detected fine. Power Information gives the expected data and the preferences work as they should.

The difference seems to be that Xfce4-power-manager has lost the ability to get its data from a USB connection, at least it has in Fedora 17.

The thing is that it seemed to work with kernels prior to 3.6.x I wish it would work again.
Comment 5 Stephen Haffly 2013-01-20 05:04:51 CET

The same problem exists in this version. I have tried the suggestion in Fedora Forum of making sure upower is running, but it makes no difference.

This is somewhat frustrating. It would be good to find out why it is not working on my desktop system with an APC UPS connected via USB yet does work fine on my netbook.
Comment 6 Harald Judt 2014-11-19 21:17:29 CET
There have been a lot of changes in the latest version. Please retry 1.4.1 and reopen if necessary.

Bug #9345

Reported by:
Reported on: 2012-10-02
Last modified on: 2014-11-19


Ali Abdallah
CC List:
2 users




screenshot of settings dialog (65.52 KB, image/png)
2012-10-16 21:26 CEST , Stephen Haffly
no flags

Additional information