! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Window manager does not start correctly: pinned windows, mouse doesn't work w...


Description Tuck Watkins 2011-12-23 01:27:14 CET
running under Xubuntu - XFCE 4.8 on an Aspire One 722-0828 netbook.

I am witnessing several behaviors which I assume are symptomatic of a single problem.  

After login I noticed on the top panel that the four workspaces I am use to seeing on the Workspace Switcher are not present. There is only one workspace visible. In fact there is only one workspace. However, the Workspace Settings application indicates in the line "Number of workspaces:"  there should be four workspaces. There is only one is listed in the "Workspace Name" box. A failure to initialize all the workspaces perhaps?

When I bring up an application such as Firefox or a file browser the window tends to be pinned in the upper left portion of the screen. When I say upper left I mean that is atop the top panel as well. The title bar for the window is missing [or not visible] and the window is not resizable. 

I am unable to use the mouse to click on a menu option when in this state. To close a window I must use a keyboard accelerator or tab and use the arrow keys to navigate to the appropriate menu choice. 

Some applications, e.g., update manager, Calibre, etc, are not pinned to the upper left corner. Instead they appear in their normal spot. The have no title bar.

Alt-tab does not switch between application windows. Alt-F2 does work. Alt-F4 does not offer to shut down an application.

As best as I can tell, the applications do what they are supposed to do, but the interface disallows the normal range gestures. 

I tried running xfwm4 from a terminal. This fixes things. Title bars come back, the mouse works with menus, the workspaces are all there, and I can work using my normal gestures. However, if I either shutdown and restart or logout then login in the behavior returns. I have to run xfwm4 again to get the system up to standard.

I have looked a various logs for some WARNING or ERROR message. But nothing stand out. Part of my problem is I am new to Linux and may simply be looking in the wrong directory. I seem to have either set something in the window manager incorrectly or hosed it by installing or removing a package.

So, I have two points:

     First, advice on how to debug this type of problem from a user stand point would be appreciated. 

     Second, if there is no logging or notification mechanism for missing modules or variables then I think this is a bug. If there is a logging or notification mechanism then please point me to the it so I can learn to use it. I will then provide a better bug report.

If this is a more serious issue than I assume it is please let me know if I can provide other information that will be of use.
Comment 1 Tuck Watkins 2011-12-23 01:29:04 CET
Since I can run xfwm4 to get back to a normal state I have a workaround for the time being.
Comment 2 Tuck Watkins 2011-12-26 18:21:36 CET
Created attachment 4043 
Copy of diff of ~/.cache/sessions/xfce4-sessions-<mumble>

I logged in then manually manually ran xfwm4. I then did a gnu-emacs diff of the xfce4 session file. The results are attached.
Comment 3 Parsifal Herzog 2012-02-11 02:54:05 CET
I also have experienced a problem like this. It happened after I started nautilus - (I am preparing for Gnome 2 demise on Mageia, by switching to Xfce).

The result of starting nautilus was that it took over managing my desktop, and started gnome-panel (even though I thought it was not configured to do so). I could not recover from that by any method I was aware of. On re-logging in, I experienced the symptoms described in the bug, also it seemed to me that Xfce was spawning a lot of spurious processes, so I imagined somehow, it was trying to start an old gnome session stored in the dot files cave of horrors. I escaped from this only by going to a backup of my home directory and restoring all the configuration files.

The problem reliably returns (actually I only tried once more) when nautilus is run, or if I start gnome-panel. 

My Xfce session settings say not to save sessions on logout, and I saved an empty session to start with; and to start KDE services, but not Gnome services on login. (I regularly use a number of KDE programs notably Ark, Dolphin and Digikam).

Running up to date Mageia 1, with Xfce 4.8.1.

Perhaps these observations will help to track down this issue.
Comment 4 Git Bot editbugs 2020-05-29 11:48:00 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/xfce/xfwm4/-/issues/66.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #8269

Reported by:
Tuck Watkins
Reported on: 2011-12-23
Last modified on: 2020-05-29


Olivier Fourdan
CC List:
2 users



Additional information