! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
process created by su dies when spawning sub-process


Description whatmeurgent 2011-05-13 20:12:35 CEST
login to a non admin account (ie. not root).
open a terminal
thunar &
focus to thunar window
select a text file
open context menu (eg. right click)
select open with mousepad

RESULT: mousepad will open. However, thunar will die.

SCENARIO #2] This also happens when the exact same procedure is performed from within a session of GNU-screen. However, GNU-screen itself is a spawned process and sucessfully spawns other non-gui sub-processes.

SCENARIO #3] This also happens when opening a .deb package file using gdebi package installer from within thunar

1] The following was tested and did not crash: xterm, screen, xterm &, focus to spawned process, xterm &
Comment 1 Mike Massonnet editbugs 2011-11-05 12:47:50 CET
Can't reproduce.
Comment 2 whatmeurgent 2011-11-07 18:33:40 CET
Created attachment 3943 
recordmydesktop documentation of how to reproduce the bug

This recording was made per Mike's request, to document how to reproduce the bug.

Note at the beginning that I press alt-tab to show the open windows, and after thunar crashes, I repeat the press alt-tab to show that thunar has crashed
Comment 3 Mike Massonnet editbugs 2011-12-03 10:35:39 CET
I tried all of this but still can't reproduce, maybe you someone else using the same distribution can try it.
Comment 4 Bruno Ramos 2011-12-03 17:16:26 CET
I was unable to reproduce this in Debian using the instruction from SCENARIO #1
Comment 5 whatmeurgent 2011-12-07 17:52:43 CET
I'm the original poster of this bug. For the recent few days, I have been unable to reproduce this bug, so I'm willing to call it closed - maybe an update fixed it - there IS a recordmydesktop video of the bug, so it wasn't my imagination, but as of Sunday, it was not reproducible for me, and as it seems not to be reproducible by anyone else, let's close this.

Bug #7618

Reported by:
Reported on: 2011-05-13
Last modified on: 2011-12-07


Xfce Bug Triage
CC List:
4 users




recordmydesktop documentation of how to reproduce the bug (4.11 MB, video/ogv)
2011-11-07 18:33 CET , whatmeurgent
whatmeurgent : review+

Additional information