! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
OpenOffice Odd Menus Disappear With Composite On


Description milkycow 2005-01-17 07:27:42 CET
When running OpenOffice with XFCE's compositor on, OpenOffice menu's next to the currently active 
one will not come up when the mouse is moved over. For example, I click on the "File" menu, and then 
move right to the "Edit" menu, the "Edit" menu does not appear, however, when I continue moving my 
mouse over to the "Tools" menu, the "Tools" menu comes up with no problems. I have tried this with 
no XFCE compositor on, and also tried WindowMaker, Gnome, KDE with and without xcompmgr on, 
the menus work fine with everything else other than XFCE with its own compositor on.

Reproducible: Always
Steps to Reproduce:
1. Start XFCE with compositing feature
2. Start OpenOffice
3. Click on any menu
4. Move mouse to the side

Actual Results:  
Menu next to the one clicked on does not appear

Expected Results:  
Menu next to the one clicked on should pop-up

Slackware 10.0, gtk 2.4.3, xorg 6.8.1 from 
Comment 1 Olivier Fourdan editbugs 2005-01-17 20:18:53 CET
I'm seeing that too. Odd indeed.
Comment 2 Olivier Fourdan editbugs 2005-01-17 21:02:24 CET
Created attachment 152 
This patch fixes the bug.
Comment 3 Olivier Fourdan editbugs 2005-01-17 21:03:03 CET
Resolving, fixed in CVS, both branches.

Bug #694

Reported by:
Reported on: 2005-01-17
Last modified on: 2009-07-14


Olivier Fourdan
CC List:
0 users



This patch fixes the bug. (581 bytes, patch)
2005-01-17 21:02 CET , Olivier Fourdan
no flags

Additional information