! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
When maximized windows are undecorated, space from the decoration is left behind


Description twilightinzero 2010-07-06 00:01:32 CEST
When maximized windows are undecorated, space from the decoration is left behind, leaving a gap between the window and the top of the screen (or the top panel). This means that applications such as Maximus don't work with XFWM4. I have tried Maximus with several other WMs such as Metacity and Openbox, and they work correctly.

To reproduce:
1. Install Maximus.
2. Run Maximus with the -s switch so that you can easily kill it once you're done.
3. Open any window, or, if running with the no-maximize or m switch, maximize any unmaximized window.

You will see the decoration be removed, but the window will not resize to occupy that space.
Comment 1 Olivier Fourdan editbugs 2010-07-06 19:46:07 CEST
Works for me.

Can you provide a screenshot and confirm the version of xfce you are running?
Comment 2 Olivier Fourdan editbugs 2010-07-06 19:46:41 CEST
(maximus 0.4.14 on Fedora 13 here)
Comment 3 twilightinzero 2010-07-06 19:54:26 CEST
Here's the screenshot: http://omploader.org/vNHV0Yg

I'm running Arch Linux, maximus 0.4.14, and xfce 4.6.2.
Comment 4 Olivier Fourdan editbugs 2010-07-06 20:29:40 CEST
weird, looks it's the top of the application that's missing, not the decorations.

does that happen with this application only (is that google chrome?) or with any?
Comment 5 twilightinzero 2010-07-06 20:34:12 CEST
All applications. That's actually Mozilla Prism running GMail, and all it has is a window decoration. Here's a screenshot of GEdit with the bug to put it in better perspective: http://omploader.org/vNHV0cg
Comment 6 Olivier Fourdan editbugs 2010-07-06 21:19:35 CEST
Right, I can reproduce, appears after the the window is moved (did not happen at first)
Comment 7 twilightinzero 2010-07-06 21:31:07 CEST
Right... due to a defect in Maximus's code (which is actually pretty easy to fix; I looked at one of the files and happened to find the mistake), windows that open maximized don't get undecorated if you have the -m switch on, even if you do still have undecorating enabled in gconf. So you have to unmaximize it and then maximize it again for the decoration to be removed and for the bug to appear. You can actually do this repeatedly if you want. Unmaximize, the decoration is put back on. Maximize, the decoration is removed. Rinse, wash, repeat. The bug should continue to appear.

Though since you've managed to reproduce, that info isn't really necessary. :)

I'll be able to easily test out any patches due to the way package creation in Arch Linux works, so when one is available, just let me know. Thank you! :)
Comment 8 twilightinzero 2010-08-06 22:25:30 CEST
I hate to be a nag, but has any research been done on this code on your guys' side? I tried looking at the code in an attempt to figure it out myself, but I can't figure it out, and am too afraid to try poking around in it. :/

I have an idea of what needs to be done: when a window is undecorated (or redecorated) and it's maximized, horizontally maximized, or vertically maximized, it needs to be resized. Just... I have no idea where to do that or how. :/
Comment 9 Denis 2010-08-24 14:42:37 CEST
Created attachment 3090 
Patch to fix this issue.

It seems, that after patching this bug does not appear. Hope that my patch will be useful.
Comment 10 Olivier Fourdan editbugs 2010-08-24 15:16:50 CEST
(In reply to comment #9)
> Created an attachment (id=3090) [details]
> Patch to fix this issue.
> It seems, that after patching this bug does not appear. Hope that my patch will
> be useful.

Patch seems correct at first sight.
Comment 11 twilightinzero 2010-08-24 15:37:19 CEST
And upon compiling xfwm4 with the patch, I can testify that it does indeed work. Works splendidly, in fact. Xfwm4 seems to work more smoothly with Maximus than Metacity did.

Thank you very much, Denis!
Comment 12 Olivier Fourdan editbugs 2010-12-03 12:50:22 CET
Fixed in master and xfce-4.6 branch, thanks for the patch.
Comment 13 Olivier Fourdan editbugs 2010-12-03 14:12:33 CET
Patch is wrong btw, it's not testing the right "flags" field (it's c->xfwm_flags and *not* c->flags)
Comment 14 Olivier Fourdan editbugs 2010-12-03 14:28:42 CET
Ok, when the use the proper flags the bug remains so the patch is useless, reopening.
Comment 15 Olivier Fourdan editbugs 2010-12-03 15:18:56 CET
Fixed now, both git master and xfce-4.6 branch.

Bug #6543

Reported by:
Reported on: 2010-07-06
Last modified on: 2010-12-03


Olivier Fourdan
CC List:
0 users



Patch to fix this issue. (1.07 KB, patch)
2010-08-24 14:42 CEST , Denis
no flags

Additional information