! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
xfwm4 with composition enabled is screwed up with latest nvidia drivers


Description Philip Langdale 2004-12-06 01:59:22 CET
I've recently tried out 4.2rc1 and I tried turning on the composition support in
xfwm4 and it's messed up with the latest nvidia drivers (66.29). I've tried on
another computer with older drivers (44.96) and with the Xephyr nested X server
and both of those work fine, so it's a specific interaction with the these drivers.

What happens is that all the windows disapper (as is usual when they are
initially redirected) but then they never appear again - I just see the desktop
and nothing else. I can still interact with the invisible windows but there's no
visual activity.

Obviously some of the blame has to lie with the nvidia drivers, but xcompmgr
works fine, so it's not an unavoidable problem.
Comment 1 Olivier Fourdan editbugs 2004-12-06 06:46:20 CET
NVidia drivers are very buggy, that a sad but proven fact.

I doubt it's a problem with xfwm4 since it works fine here (with NVidia btw)
Comment 2 Olivier Fourdan editbugs 2004-12-06 11:51:34 CET
Can you try this one, I'm really not seeing anuthing wrong:


BTW, I'm decreasing severity to minor, the compositor is not critical and not
even enabled by default.
Comment 3 Olivier Fourdan editbugs 2004-12-06 21:22:07 CET
ok, the only explanation I see is the following: xfwm4 uses an additional buffer
for redering the screen, and I suspect that your video card runs out of mem for
some reason (did you try reducing the resolution?)

BTW, I removed that additional buffer, so things might have improve. If not,
ahumm, that prolly stay as "won't fix" because it works for me and I have no
idea what else could be wrong.
Comment 4 Olivier Fourdan editbugs 2004-12-06 21:25:37 CET
btw, you can try the following source that includes the "fix":

Comment 5 Brian J. Tarricone (not reading bugmail) 2004-12-06 23:01:44 CET
i'm almost certain this is a bug with the latest nvidia drivers.  i had the same
problem, you mention, and rolled back to the previous version, and it was fine.
 i did a bunch of googling, and it seemed to confirm that.

note that (for me at least), the problem exists regardless of whether or not
composite is enabled.  it seems to be a compatibility problem specific to nvidia
v6629 and x.org 6.8.x.
Comment 6 Philip Langdale 2004-12-07 05:59:14 CET
With the compositor disabled (at runtime, still compiled in), it works fine -
just to respond to Brian's comment.

I tried your tweaked build and it didn't help - so I doubt it's a lack of memory
issue - which I suspect would manifest itself rather more spectacularly, and I
assume the nvidia drivers would use agp if they needed to anyway.

Oh well. I wouldn't mind downgrading if it wasn't for the fact that older
versions of the drivers are basically guaranteed to crash the X server within 20
minutes. :-)
Comment 7 Jasper Huijsmans editbugs 2004-12-12 10:26:17 CET
Ok, from the discussion I conclude this is a bug in XOrg/Nvidia driver, so I'm
closing it now.

Bug #573

Reported by:
Philip Langdale
Reported on: 2004-12-06
Last modified on: 2009-07-14


Olivier Fourdan
CC List:
0 users



Additional information