! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Unable to change workspaces using mouse


Description Cheng Zhou 2004-11-28 18:38:04 CET
Similar to bug #421. When I enable the "Wrap Workspaces" option in the Windows
Manager options, I can not change workspaces using the mouse. However, if I
enable the "Wrap Workspaces while dragging a window" option, I can change
workspaces by dragging a window but am not able to do so using just the mouse.
Comment 1 Olivier Fourdan editbugs 2004-11-29 20:12:46 CET
I'm not seeing anything wrong here. Can you explain exactly what is your current
configuration , what behaviour you are experiencing and what you get?
Comment 2 Cheng Zhou 2004-11-30 15:57:43 CET
What aspect of my configuration are you interested in?
I'm using Gentoo 2004.3 on a Pentium 4. Here are versions of things I'm using:
XFCE: 4.1.99
XOrg: 6.8.0 with Composite extensions
Kernel: 2.6.8
GCC: 3.3.4

Are there log files, config files or anything else I can attach for reference?
Just FYI other users on the Gentoo forum report no problems with this feature
either so perhaps mine is an artifact of upgrade from 4.0.6 to 4.1.99? Only odd
thing is that this worked perfectly in 4.0.6
Comment 3 Olivier Fourdan editbugs 2004-11-30 20:50:37 CET
I'd like to know how yo configured your desktop - what options are set (like
wrap workspace with mouse, wrap workspace while dragging window, etc.), if you
customized you xfwm4rc, if the panel is vertically or horizontally, what
behaviour you are seeing wrong precisely.
Comment 4 Cheng Zhou 2004-12-01 02:46:53 CET
Here's the contents of my ~/.config/xfce4/mcs_settings/xfwm4.xml

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE mcs-option SYSTEM "mcs-option.dtd">

        <option name="Xfwm/BoxMove" type="int" value="0"/>
        <option name="Xfwm/BoxResize" type="int" value="0"/>
        <option name="Xfwm/ButtonLayout" type="string" value="OTS|HMC"/>
        <option name="Xfwm/ClickToFocus" type="int" value="1"/>
        <option name="Xfwm/DblClickAction" type="string" value="maximize"/>
        <option name="Xfwm/FocusNewWindow" type="int" value="1"/>
        <option name="Xfwm/FocusRaise" type="int" value="0"/>
        <option name="Xfwm/KeyThemeName" type="string" value="default.keys"/>
        <option name="Xfwm/RaiseDelay" type="int" value="250"/>
        <option name="Xfwm/RaiseOnClick" type="int" value="1"/>
        <option name="Xfwm/SnapToBorder" type="int" value="1"/>
        <option name="Xfwm/SnapToWindows" type="int" value="0"/>
        <option name="Xfwm/SnapWidth" type="int" value="10"/>
        <option name="Xfwm/ThemeName" type="string" value="Curve"/>
        <option name="Xfwm/TitleAlign" type="string" value="center"/>
        <option name="Xfwm/TitleFont" type="string" value="Verdana 9"/>
        <option name="Xfwm/WrapResistance" type="int" value="1"/>
        <option name="Xfwm/WrapWindows" type="int" value="1"/>
        <option name="Xfwm/WrapWorkspaces" type="int" value="1"/>

My panel is oriented horizontally across the bottom of my screen. In the
settings applet for Window Manager, I've selected both
Wrap workspaces when the pointer reaches a screen edge as well as
Wrap workspaces when dragging a window off the screen.
The edge resistance is set to small, but changing it doesn't seem to affect
whether my scenario works. With these settings, I can switch desktops by
dragging a window off of the left or right edge of my screen. However, if I just
try to move the mouse point off of the edge of a screen, no desktop switching
Comment 5 Olivier Fourdan editbugs 2004-12-01 21:15:51 CET
I see nothing wrong, I don't actually see the issue.

Just to make sure, as the screen is not "extensible", you need to keep the
pointer on the scren edge and move the mouse slightly up and down to trigger the

Does that help?
Comment 6 Cheng Zhou 2004-12-02 04:19:46 CET
Unfortunately no really. I've tried to wiggle the mouse pointer up and down at
the screen edge to no avail. The switching behavior works exactly as expected
when I am dragging a window so I think I am activating the funtionality ok but
it doesn't seem to work when I am using just the mouse pointer with no window
dragging. I'm sorry to have taken up so much of your time. If I can produce more
helpful pointers as to the problem, I will update this issue. Is there a way to
enable tracing in xfw4?
Comment 7 Olivier Fourdan editbugs 2004-12-02 12:46:27 CET
A few aditinal questions:

- Do you have multiple screens  (ie more than a single screen attached to your
computer)? => wrap worspace is disabled with multi-screen.

- Can you run "xfwm4 --version" and post the result?

Thanks in advance.
Comment 8 Olivier Fourdan editbugs 2004-12-02 18:50:02 CET
Good news, I'm able to repduce the problem.
Comment 9 Olivier Fourdan editbugs 2004-12-02 21:52:23 CET
Ok, fixed in CVS. Thanks for poitning this out. The key point was that the
problem arised only when the compositing manager is enabled.

Please note that anon CVS lags, so you may not get the fix immediatly.

Bug #551

Reported by:
Cheng Zhou
Reported on: 2004-11-28
Last modified on: 2009-07-14


Olivier Fourdan
CC List:
0 users



Additional information