! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
input focus lost after the auto-complete window is canceled in Eclipse IDE


Description michael 2009-03-29 03:02:36 CEST
linux version: xubuntu 8.04.1 (sorry, I forget getting xfce/xfwm4 version , it's in my office. I will confirm their versions later)

I have installed Eclipse(ganymede) on xubuntu for my Java development. If you input some object, then you type "." to get its member, an auto-complete menu will pop up, if you press "Esc" to cancel it, you will find the input focus lost. The cursor is still blinking there, but anything you type is useless, even if you use your mouse to click the current edit area or Eclipse window(except the window title). If you click the window title, which is decorated by xfwm4, you will find you get the input focus back now. I tried setting the options in Window Manager, but it didn't work. So I think it's something wrong with xfwm4.

Tested it with sun-java-5 and sun-java-6 on xubuntu , both failed. 
Tested this issue on Gentoo Linux with Gnome desktop environment, it works well.

Reproducible: Always

Steps to Reproduce:
1. type an object in Eclipse IDE 
2. type "." to get its members, and auto-complete menu pops up
3. press "Esc" to cancel the popped menu

Actual Results:  
After menu disappeared, the input focus is lost, user shall to click Eclipse window title to get it back.

Expected Results:  
After menu disappeared, the input focus will be back to editor automatically.
Comment 1 Olivier Fourdan editbugs 2009-03-29 11:53:54 CEST
This by no mean a "high/major" issue, this not crasher, you don't loose your work, there is no security threat, geez, come on!
Comment 2 Olivier Fourdan editbugs 2009-03-29 13:17:09 CEST
Works for me, though, installed Eclipse 3.4.2 with Openjdk 1.6.0 on Fedora 10 with Xfce 4.6 and there is no focus issue when cancelling the completion menu.

Can you try to reproduce in xfce 4.6?
Comment 3 Olivier Fourdan editbugs 2009-03-29 14:46:29 CEST
No matter how hard I try, I cannot reproduce that bug.

I tried with sun JRE 6u13 with xfwm4 4.4.1 and it works just fine. I also tried in focus follow mouse, ditto, no problem.
Comment 4 Olivier Fourdan editbugs 2009-03-29 17:44:50 CEST
That really looks like this bug:


Do you use scim?
Comment 5 michael 2009-03-30 05:38:23 CEST
(In reply to comment #4)
> That really looks like this bug:
>     https://bugs.launchpad.net/ubuntu/+source/scim/+bug/293001
> Do you use scim?

Thanks a lot.
I had it installed. After I uninstalled it, it works now.

I tried openbox as the window manager, it failed too.

Later I tried gnome:
sudo aptitude install gnome-core
it also failed.

It's NOT an issue with xfce/xfwm4 INDEED.
Comment 6 michael 2009-03-30 05:42:20 CEST
xubuntu xfce version I tested:

xfce 4.4.2
xfwm4 4.4.2 revision 26361
Comment 7 Olivier Fourdan editbugs 2009-03-30 11:56:44 CEST
(In reply to comment #5)
> It's NOT an issue with xfce/xfwm4 INDEED.

Good, that explains why I could not reproduce it...

Bug #5164

Reported by:
Reported on: 2009-03-29
Last modified on: 2009-07-14


Olivier Fourdan
CC List:
0 users



Additional information