Configure script cannot complete. The configure script for xfce4-cpu-freq-plugin-0.0.1 only allows for libxfcegui4-1.0 >= 4.3.90.
Current version of libxfcegui4.i386 is version 4.4.2-1 for fc7
Sorry for not responding when this issue was problematic. I am not quite sure why such restriction was put in, but it might have been on purpose due to known incompatibilities with older version of libxfcegui4. In any case, distros (Fedora included) now ship with new enough version libxfcegui4, so I don't think it is worth the time to investigate what version of libxfcegui4 is actually required.