! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Keyboard shortcuts on numeric keypad are ineffective.
Keyboard Settings


Description Lee 2008-06-27 14:37:21 CEST
I've tried various attempts to set-up shortcuts on the numeric keypad with the Settings Manager, under Keyboard / Shortcuts, with both NumLock on and off as well as Ctrl as a modifier.  Pressing the keys nearly always results in the default action being sent to the active window rather than being overridden.  The same bindings *do* work under Window Manager / Keyboard, but those actions are fixed 'window shortcuts' that don't provide the required functionality.
Comment 1 Lee 2008-06-28 10:54:27 CEST
There seems to be a similar issue with one or two other keys - the Keyboard Preferences / Shortcuts editor allows you to define against keys but doesn't trigger the event when those same keys are pressed, e.g. the left 'Windows' key on a modern keyboard shows as 'Super+Super_L' but both it and the right 'Windows' key are ineffective.
Comment 2 charlie-tca 2010-09-05 12:51:30 CEST
This bug has also been reported on Ubuntu Launchpad as:

From the launchpad report:

Version of xfce4:

I use Xubuntu 10.04.1.
Keyboard shortcuts including number keys in number pads do not work.
You can use non-number keys in number pads such as "*"(MULTIPLY) and "+"(ADD),
but number keys ("0", "1", ...) won't work.

Reproduction Procedure:

1. Activate "xfce4-settings-manager".
2. Click on "Keyboard", select "Application Shortcuts" tab.
3. Add a shortcut.
  Command : zenity --info
  Shortcut: KP_Divide (Type "/" in your number pad)
4. Hitting "/" key in the number pad shows a dialog box.
5. Then, add another shortcut.
  Command : zenity --info
  Shortcut: KP_6 (Type "6" in your number pad with NumLock on)
6. This time, hitting "6" key does not show any dialog box.

I tried <Control>KP_6, <Alt>KP_6 and <Super>KP_6 too, but none of them worked.
I tried some other number keys in the number pad, but the result was the same.
Comment 3 Silvio Knizek 2011-02-19 22:25:10 CET
This bug still exists in 4.8.1 on Arch Linux and is really annoying.
Comment 4 Richard Hitt 2012-09-12 04:06:17 CEST
Created attachment 4626 
Patch for xfce-shortcuts-grabber.c

Fix for Numeric-KeyPad keyboard shortcuts
Comment 5 Richard Hitt 2012-09-12 04:18:01 CEST
Fixed.  I installed a fresh current xubuntu 12.04.1 and verified that the failure persists as reported in Comment 2.  Then I built and installed libxfce4kbd with the above patch (Comment 4) and verified that the Comment-2 procedure yielded the desired results, namely, hitting KeyPad 6 results as expected in executing the shortcut command correctly.

I noted that Fedora 17 xfce did not have the problem, so I compared its libxfce4ui source with xubuntu 12.04.1's.  Only the single source file was different, and so thanks go out to whoever made that fix in Fecdora-17-xfce.

Thanks to killermoehre@freenode:#xfce who suggested to me (richtroye) that this bug be worked on!
Comment 6 jazztickets 2012-11-16 23:39:54 CET
Still happens on Xubuntu 12.10, which has Xfce 4.10

KP_0 through KP_9 do not work.

KP_Divide, KP_Add, KP_Subtract, and KP_Multiply however do work.
Comment 7 Jérôme Guelfucci editbugs 2012-12-30 15:48:13 CET
Fixed in git master of libxfce4ui with commit 	6633a2deed6ab60fbb02c157a8c9499c1824fb4e.
Comment 8 Jérôme Guelfucci editbugs 2013-03-17 10:57:03 CET
*** Bug 9923 has been marked as a duplicate of this bug. ***

Bug #4178

Reported by:
Reported on: 2008-06-27
Last modified on: 2013-03-17
Duplicates (1):
  • 9923 keybindings involving keypad-numbers are NOPs


Jannis Pohlmann
CC List:
11 users




Patch for xfce-shortcuts-grabber.c (1.19 KB, patch)
2012-09-12 04:06 CEST , Richard Hitt
no flags

Additional information