! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
xfce4-mixer mutes left channel (m-audio revolution)


Description mvoncken 2007-08-27 19:08:08 CEST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20061201 Firefox/ (Ubuntu-feisty)
Build Identifier: 

Soundcard : m-audio Revolution 5.1 (Envy24HT)
Distribution:xubuntu feisty.

xfce4-mixer resets the "H/W" setting from "PCM out" to  "H/W in 1" every ~15 seconds 

The xfce4-mixer is out of sync with alsamixer.
Alsamixer shows the actual state of "H/W" while xfce4-mixer keeps resetting to "H/W in 1" , but xfce4-mixer does not reflect that change in the gui and says it's still "PCM out".

Reproducible: Always

Steps to Reproduce:
#multiple reproduction cycles, they don't fit your bug form.
Actions on my pc:
Start playing a music file.
-no sound on left channel
start alsa-mixer: change "H/W" to PCM-out.
sound on left channel (for 15 seconds), gets reset to "H/W in 1"
-repeat the steps above as many times as you like.
kill xfce4-mixer
-problem solved.
start xfce4-mixer from terminal
-15 seconds later : no sound on left chan.
-alsamixer displays "H/W" is "HW in 1"
-xfce4-mixer displays "H/W" is "PCM out"
set "H/W" on xfce4-mixer to something else and set it back to "PCM out"
-no result
close xfce4-mixer gui
start xfce4-mixer from term
-xfce4-mixer still displays "H/W" is "PCM out"
-alsamixer still displays "H/W" is "HW in 1"
kill all xfce4-mixer processes, set H/W back using alsa mixer
-problem solved

Possibly totally unrelated , but there are more problems with the left channel on this card.
But that is fixed by changing the volume once. 
And it's not recurring every xx seconds like my problem.

Comment 1 mvoncken 2007-08-27 19:28:56 CEST
I copied this bug to : https://bugs.launchpad.net/ubuntu/+source/xfce4-mixer/+bug/135133
Comment 2 Guido Berhoerster 2012-09-28 12:00:27 CEST
This was reported against version 4.4, since then xfce4-mixer has been rewritten to use gstreamer. If this is still an issue please open a new bug.

Bug #3503

Reported by:
Reported on: 2007-08-27
Last modified on: 2012-09-28


Xfce Bug Triage
CC List:
2 users



Additional information