! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
urxvt -bl (borderless) does not work, eg it will keep borders


Description Michael Pflüger 2007-08-10 23:09:44 CEST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20070807 Firefox/
Build Identifier: 

I have an amd64 box with xfce 4.4.1, urxvt 8.2, xorg 7.2, gtk+ 2.10.14
urxvt -bl (borderless) does not work with xfce, while it works with afterstep and openbox on the same machine.
It also works on another 32bit box i have, although it's software versions (besdies xfce and urxvt) are a bit older (like xorg 7.1).

I also tried the latest daily snapshot of xfwm4 (xfwm4 version 4.5.0 (revision 25961)), and it has the same problem.

I noticed something with that version, however: when i run urxvt with the borderless switch, the sticky button in the titlebar does *not* appear, while it does appear when i run urxvt without the borderless switch.

Reproducible: Always

Steps to Reproduce:
1. start urxvt with the -bl switch :)
Comment 1 Michael Pflüger 2007-08-11 10:41:16 CEST
urxvt 8.3, released a few days ago, fixes this problem.
In the changelog i found:

- zero-initialise mwmhints, this seems to solve all sorts of minor

which might be the relevant change.
I guess this bug's status can be changed to invalid, though i'm not sure why it worked with the other window managers with the older versions of urxvt.
Comment 2 Olivier Fourdan editbugs 2007-08-11 21:31:18 CEST
I don't think it's a but with xfwm4, really.

Bug #3450

Reported by:
Michael Pflüger
Reported on: 2007-08-10
Last modified on: 2009-07-14


Olivier Fourdan
CC List:
0 users



Additional information