! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Xfce shortcuts with "Alt" are not working after adding: Option "XkbLayout" to...


Description rayfire 2007-04-30 17:31:19 CEST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv: Gecko/20070309 Firefox/
Build Identifier: 

After adding:
Option "XkbLayout" "us,lt"
to xorg.conf file, in order to support different language layouts, after starting xfce shortcuts with "Alt" are not working anymore. (Alt+Tab, Alt+F4...), Shortcuts without "Alt" works OK (Ctrl+F1, Ctrl+F2, Ctrl+Esc...)

Reproducible: Always

Steps to Reproduce:
1. Exit from GUI (Xorg or anything)
2. Edit xorg.conf file
3. Edit keyboard section in "InputDevice"
4. Add Option "XkbLayout" "us,lt"
My section looks like:
Section "InputDevice"
	Identifier  "Keyboard1"
	Driver      "kbd"
	Option	    "AutoRepeat" "500 30"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc101"
	#caused to stop working "Alt" xfce shortcuts
	Option	    "XkbLayout" "us,lt,ru(phonetic)"
	Option      "XkbOptions" "grp:ctrl_shift_toggle"

5. Start again Xorg with xfce
6. Try closing applications "Alt+F4" or switching "Alt+Tab"
Actual Results:  
Everything works, I can switch layouts, but shortcuts are not working, I can not close window by Alt+F4, or switch window by Alt+Tab.

Expected Results:  
Shortcuts inside xfce should be working as they worked before.

2.6.21 kernel (same was with older kernel)
Xorg 7.2
Glib 1.2.10
GlibC 2.3.6
GTK+ 2.10.9
Xfce 4.4.1
Comment 1 Olivier Fourdan editbugs 2007-05-01 12:19:46 CEST
Indeed. That's odd. it works with xfce 4.0, but not with 4.2 nor 4.4
Comment 2 Olivier Fourdan editbugs 2007-05-02 21:16:11 CEST
Ok, that was a tough one...

I believe this is now fixed in svn. You can try by using one of the current snapshots of xfwm4 and xfce-mcs-plugins available here:


Can you try these?
Comment 3 rayfire 2007-05-03 17:51:34 CEST
Well done. Looks like it works like it should. I have tried xfce-mcs-plugins-4.5.0svn-25673.tar.bz2

Now shortcuts are working as they should, also group switching declared in xorg.conf works as before.

Here this can be marked as resolved bug.

However now keyboard module from xfce is missing (I don't know if it is a problem or just in process of modification in new version):
Xfce settings manager error: no such plugin "keyboard", when trying to open keyboard module to edit shortcuts.
Comment 4 Olivier Fourdan editbugs 2007-05-04 08:12:54 CEST
(In reply to comment #3)
> However now keyboard module from xfce is missing (I don't know if it is a
> problem or just in process of modification in new version):

Yes, my bad, it is fixed with rev. 25675

Bug #3194

Reported by:
Reported on: 2007-04-30
Last modified on: 2009-07-15


Olivier Fourdan
CC List:
0 users



Additional information