! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Unable to alt-tab when all apps are minimized


Description Scott H 2006-10-26 03:44:14 CEST
In the window manager tweaks settings, I have "include hidden (i.e. iconified) windows" checked for cycling. If I minimize an application, it correctly shows up in the alt-tab dialog. However, if I minimize ALL of my applications and press alt-tab, the dialog does not show up. If I middle-click on the desktop and restore an application, alt-tab once again works.

xfwm4-svn 23418-1
Comment 1 Olivier Fourdan editbugs 2006-10-26 14:05:21 CEST
I'm not seeing that here.
Comment 2 Olivier Fourdan editbugs 2006-10-26 16:57:48 CEST
Do you have any additional information on how to reproduce that issue? Can you try with current SVN (not that any change occurred in that portion of code as far as I can remember).

Also, you may attache the $HOME/.config/xfce4/mcs_settings/wmtweaks.xml, $HOME/.config/xfce4/mcs_settings/xfwm4.xml and some hints on what application you are running (how many panels, list of applications, etc.)
Comment 3 Scott H 2006-10-28 15:36:20 CEST
Created attachment 843 
Comment 4 Scott H 2006-10-28 15:36:56 CEST
Created attachment 844 
Comment 5 Scott H 2006-10-28 15:38:27 CEST
Argh.. this is really weird, and I'm starting to wonder if it's not a xfce issue (maybe Xorg?). As far as reproducing it, I've found out that sometimes it works and sometimes it doesn't. Right now it works consistentyly - minimize everything, alt-tab doesn't work, but yesterday it was working for the most part.

However, I've noticed something else. I have one of those "game" terminals that toggles when I press F1. Whenever the alt-tab doesn't work with all apps minimized, the F1 key doesn't induce the terminal either. Yet as soon as I have an application open, both work again. I can't imagine why this is, but it happens very often, although not every time. It's almost like X (?) isn't getting the keystrokes? If this isn't an xfce issue, feel free to close this :/

The files you requested are attached. As far as your questions go, I typically have firefox, a urxvt or two, and irssi open. I don't use a panel, although I was able to reproduce this with xfce4-panel running.
Comment 6 Olivier Fourdan editbugs 2006-10-28 18:59:50 CEST
You probably have an application that gets the focus once all others are hidden, preventing the WM from receiving the Alt+Tab key press.

Can you try running xlsclients from a terminal and post the output?
Comment 7 Scott H 2006-10-28 19:38:20 CEST
I minimized everything, verified that it was still happening, then opened a new terminal and ran that command:

machine  urxvt -name irssi -g 80x24+0+451 -e irssi
machine  urxvt
machine  xfwm4
machine  xfdesktop
machine  xfce-mcs-manager
machine  firefox-bin
machine  transmission-gtk
machine  urxvt -pe 'kuake<F1>' -bl -name gameterm
Comment 8 Olivier Fourdan editbugs 2006-11-01 22:26:13 CET
Can you try with a recent build from SVN trunk?
Comment 9 Scott H 2006-11-04 16:50:16 CET
Just tried it with xfwm4 revision 23619 and I can still reproduce it sometimes. I've not yet figured out what it takes to trigger it either, it seems to work or not work randomly..
Comment 10 Olivier Fourdan editbugs 2006-11-04 19:17:25 CET
Ok, I can reproduce the problem. The missing bit is that you probably have no icon on xfdesktop (ie xfdesktop doesn't accept input focus)
Comment 11 Scott H 2006-11-04 19:31:08 CET
Ahh, that is correct! I neglected to mention that (didn't think xfdesktop needed focus). Hopefully that means a fix is in the works. Although it still bugs the heck out of me that alt-tab sometimes worked and I can't see the pattern :P
Comment 12 Olivier Fourdan editbugs 2006-11-04 22:46:51 CET
That might be fix with revision 23704, can you try?

(In doubt, you can always grab an up-to-date snapshot from http://foo-projects.org/~olivier/preview/)
Comment 13 Scott H 2006-11-06 06:21:59 CET
So far it seems to be working! I'll update this in a few days with the verdict since it was a sporadic thing, but it has worked every time thus far.

One small issue, related to this and a previous file request I had made. If you have all applications minimized and then start alt-tabbing, pressing escape to cancel the alt-tab action seems to default to showing the first item in the alt-tab list. I'd expect it, in the situation, to instead not show any applications since I had none shown before I started alt-tab'ing. But it's a minor inconvenience.
Comment 14 Olivier Fourdan editbugs 2006-11-09 22:00:30 CET
I believe this is fixed.

Bug #2472

Reported by:
Scott H
Reported on: 2006-10-26
Last modified on: 2009-07-14


Olivier Fourdan
CC List:
0 users



wmtweaks.xml (1.50 KB, text/xml)
2006-10-28 15:36 CEST , Scott H
no flags
xfwm4.xml (1.14 KB, text/xml)
2006-10-28 15:36 CEST , Scott H
no flags

Additional information