! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Clicks are not working on Behringer's X-AIR-Edit


Description Ёж 2020-01-07 19:57:59 CET
Сразу извиняюсь! Переведено через Google-переводчик с русского языка, по-этому могут возникнуть ошибки перевода.
Дорогие разработчики XFCE!
Пишет вам пользователь, недавно перешедший на Linux с Windiws, но уже немного поработавший с Linux. Не судите строго. 
И прошу помощи в решении проблемы.
Пользуюсь цифровым микшером Behringer XR18 около 4-5 лет. Решил перйти на Linux. Пробовал множество DE. Пробовал сначала MATE, потом KDE, Cinnamon, Unity, Gnom 2, Gnom 3, даже Budgie. Больше всего понравился XFCE. К тому же на нём основан Ubuntu Studio. 
Но возникла проблема: на всех DE хорошо работает программа X-AIR-Edit 1.5 - приложение для цифрового микшера Behringer XR18, но не работает на XFCE. Запускается версия 1.5, но кнопки не работают. Более старые версии вообще даже не запускаются.
На Ubuntu studio или даже на Linux mint XFCE при установке любого другого DE - эти DE работают не полноценно. То терминал не запускается, то файлового менеджера нет, то настройки системы не открываются.
--- Подскажите как запустить X-AIR-Edit в DE XFCE.
Мой обратный адресс: yozh.1981@mail.ru
С нетерпением жду ответа в решении этой проблемы.
Заранее спасибо! 
P.S.: Возможно это поможет перейти с windows на lunux не только мне, но и другим пользователям (музыкантам и другим медийным личностям).


I apologize right away! Translated via Google translator from Russian, therefore translation errors may occur.
Dear XFCE Developers!
A user who recently switched to Linux with Windiws, but has already worked a bit with Linux, writes you. Do not judge strictly.
And I ask for help in solving the problem.
I have been using Behringer XR18 digital mixer for about 4-5 years. I decided to switch to Linux. Tried a lot of DE. I tried first MATE, then KDE, Cinnamon, Unity, Gnom 2, Gnom 3, even Budgie. Most of all I liked XFCE. In addition, Ubuntu Studio is based on it.
But there was a problem: the X-AIR-Edit 1.5 program works well on all DEs, an application for the Behringer XR18 digital mixer, but it does not work on XFCE. Version 1.5 starts, but the buttons do not work. Older versions do not even start at all.
On Ubuntu studio or even on Linux mint XFCE when installing any other DE - these DEs do not work fully. Either the terminal does not start, then there is no file manager, then the system settings do not open.
--- Tell me how to run X-AIR-Edit in DE XFCE.
My return address: yozh.1981@mail.ru
I look forward to hearing from you in resolving this problem.
Thanks in advance!
P.S .: Maybe this will help me switch from windows to lunux not only to me, but also to other users (musicians and other media personalities).
Comment 1 Andre Miranda editbugs 2020-01-09 05:14:07 CET
I can reproduce the problem, clicks are not working. Replacing xfwm4 with openbox makes the application behave correctly. Moving to the correct product.
Comment 2 Andre Miranda editbugs 2020-01-09 05:16:46 CET
By the way, this is here I downloaded the app:

It's interesting that is only uses OpenGL, no gtk or qt. Seems like it's made with imgui or similar.
Comment 3 Andre Miranda editbugs 2020-01-11 04:57:30 CET
More info:
- That app uses Juce as the GUI/Audio framework (reveled by symbols of the non-stripped binary)
- Juce's Projucer works fine (hopefully it also uses Juce)
- With Xfwm 4.12 clicks work, so this is very likely a regression
- git bisect points at this commit: https://git.xfce.org/xfce/xfwm4/commit/?id=ef33ff7
Comment 4 Git Bot editbugs 2020-04-05 17:53:44 CEST
Olivier Fourdan referenced this bugreport in commit aa3e3cac7fb200f65f50bed32309c002775ed68a

device: Use standard grabs for passive button grabs

Comment 5 Andre Miranda editbugs 2020-04-05 22:09:47 CEST
The fix works for me, thanks!
Comment 6 Andre Miranda editbugs 2020-04-05 23:05:31 CEST
Unfortunately that commit caused a regression, now I can't move windows with Alt+drag.
Comment 7 Olivier Fourdan editbugs 2020-04-06 09:19:39 CEST
(In reply to Andre Miranda from comment #6)
> Unfortunately that commit caused a regression, now I can't move windows with
> Alt+drag.

You mean *any* window or just the X-AIR-Edit window?

Here, Alt+LMB works fine for all but the X-AIR-Edit window.

The reason it does not work with the X-AIR-Edit window is because the application works by grabbing the button, which is the reason it broke with clicking when xfwm4 was issuing an Xi2 button grab itself. But that's not a regression, it's because of the way the application itself works.

It's a very peculiar app...
Comment 8 Andre Miranda editbugs 2020-04-06 17:44:40 CEST
(In reply to Olivier Fourdan from comment #7)
> (In reply to Andre Miranda from comment #6)
> > Unfortunately that commit caused a regression, now I can't move windows with
> > Alt+drag.
> You mean *any* window or just the X-AIR-Edit window?

Any window (e.g. Thunar, Terminal), I can't resize or move them, reverting that commit solves the problem.
Comment 9 Olivier Fourdan editbugs 2020-04-06 18:08:29 CEST
Humm, can you try https://github.com/ofourdan/xfwm4/tree/no-xinput2 then?
Comment 10 Olivier Fourdan editbugs 2020-04-07 20:03:53 CEST
Those commits:


Should fix the issue, although they were linked to the wrong bug, sorry my bad...
Comment 11 Andre Miranda editbugs 2020-04-11 03:41:41 CEST
Thanks, now clicks are working with X-AIR-Edit and I can use alt+drag and alt+rmb to move/resize other apps.
Comment 12 Git Bot editbugs 2020-05-29 12:33:14 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/xfce/xfwm4/-/issues/367.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #16347

Reported by:
Reported on: 2020-01-07
Last modified on: 2020-05-29


Olivier Fourdan
CC List:
2 users




Additional information