! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Window border vanishes when resizing vertically in composite mode


Description Fabian Nowak editbugs 2006-03-28 20:56:42 CEST
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686; de) Opera 8.51
Build Identifier: svn20625

Having switched on composite mode and partial transparency fr both resize and window border, after some resizements the window border vanishes until the window gets redrawn, i.e. after switching desktop or maximizing/unmaximizing or resizing horizontally; but not after moving.

Reproducible: Always

Steps to Reproduce:
1. Resize vertically
2. Continue resizing; with or without break in between...

Actual Results:  
Top window border vanishes more and more

Expected Results:  
Does not vanish, but gets redrawn just like when resizing horizontally.

Comment 1 Olivier Fourdan editbugs 2006-03-29 17:19:05 CEST
What version of Xorg do you use? Looks like bug that was in Xorg 6.8.x
Comment 2 Fabian Nowak editbugs 2006-03-29 17:46:39 CEST
Xorg 6.9.0. Did i make clear, that it vanishes more and more, not imediately with the first resize? See http://mitglied.lycos.de/timshome/misc/broken_border.png .
Comment 3 Olivier Fourdan editbugs 2006-03-29 20:04:19 CEST
I really cannot reproduce that bug, not with NVidia proprietary driver nor nv opensource driver.

If you look at the panel, the clock and systray icons are of different opacity which is a bug that showed typically in Xorg 6.8.0.

Can you try this, run the following command from a terminal ?

xdpyinfo | grep version
Comment 4 Fabian Nowak editbugs 2006-03-29 20:16:30 CEST
In one point, you are right, some libraries are 6.8.2:

$ xdpyinfo | grep version
version number:    11.0
X.Org version: 6.8.2

the systray icons are displayed properly, dunno what made them have an opaque background in the screenshot.

funny enough, xbase-clients, x11-common and whatever pretend to be 6.9.0.dfsg.1-5, which package might still be from 6.8.2 then? actually, i doubt that any package is still 6.8.2, as apt-get upgrade should have updated the full x11 stuff. Never mind, you can close this bug, i'll go hunting 6.9-pretending packages :-(
Comment 5 Olivier Fourdan editbugs 2006-03-29 20:28:50 CEST
Switch to dapper ;)

(But one advise though, don't upgrade, that turned to be a painfull process for me, do a fresh install if you can)

BTW, I had a patch to fix that bug in 6.8.x and I even built the Debian packages sometime ago.
Comment 6 Fabian Nowak editbugs 2006-03-30 11:22:56 CEST
(In reply to comment #5)
> Switch to dapper ;)
wouldn't have solved the problem, it was due to xserver-xorg dependencies on nvidia-glx which was held due to the introduction of legacy packages for older nvidia-cards, like my GeForce 2.

now everything is solved using the legacy nvidia driver and the updated package xserver-xorg-6.9.0  (the panel transparency also works better now).

> BTW, I had a patch to fix that bug in 6.8.x and I even built the Debian
> packages sometime ago.
hmm, i live using svn version of any xfce component since half a year or so...

Bug #1620

Reported by:
Fabian Nowak
Reported on: 2006-03-28
Last modified on: 2009-07-14


Olivier Fourdan
CC List:
0 users




Additional information