! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
sdl apps get no window decorations and cannot be moved


Description Alexander Toresson 2006-03-27 19:24:13 CEST
Well, I've got problems with sdl apps again. I'm on xfwm4 revision 20608, though I've had this for a while. First assumed it was a bug in the sdl application itself, but that doesn't seem likely, after I had found out that it affects all sdl apps.

All sdl apps get no window decorations, and when I try to move them with alt-drag, they move in the pager but the window itself does not move. Sdl windows also disappear if I killrestart xfwm4. I've got "intelligent" window placing enabled, and when an sdl app is started with no other windows running on that workspace, it's placed in the upper left corner of the screen, but offset to the left and down by the left and upper border widths of the xfwm4 theme.
Comment 1 Olivier Fourdan editbugs 2006-03-27 19:42:34 CEST
Compositor is enabled by default and SDL does not support it well I think.

Can you either try to:

- start xfwm4 with --compositor=off
- set env var XLIB_SKIP_ARGB_VISUALS=1 prior to run the app

Comment 2 Alexander Toresson 2006-03-27 19:54:55 CEST
Oh, XLIB_SKIP_ARGB_VISUALS=1 worked. I had Option "Composite" "Enable" in my xorg.conf after experimenting with composite, but I have no dri enabled currently and thus no composite. I thought. (at least I have no composite manager running, neither in xfwm4 nor anything else). I'll try commenting that out and restart X. Thank you.
Comment 3 Alexander Toresson 2006-03-27 19:58:58 CEST
Restarted X with Option "Composite" "Enable" commented out, and it works as it should. Thank you :) Oh, and resolved invalid.
Comment 4 Brendan Becker 2006-10-24 00:38:48 CEST
I am experiencing this problem, but the proposed solutions did not help. I do not have compositing, as I am using XFree86 Version 4.3.0. Is there any hope for me here?

Also, I notice this problem with xv (the image viewer) and a few other non-SDL apps.
Comment 5 Olivier Fourdan editbugs 2006-10-24 07:23:17 CEST
What apps? What version? Which version of xfce?.. 

I cannot help if I can't reproduce the problem.
Comment 6 Olivier Fourdan editbugs 2006-10-24 10:40:44 CEST
I just tried Xv 3.10a (yeah, digging from dust ;) and it works. Xfwm4 uses render for the decorations so maybe the render version in XFree 4.3.0 are too old?

This is odd, as I've tested on Debian Sarge that ships with XFree86 4.3.0 and everything works fine.

But definitely, knowing what Xfce version you have would help...
Comment 7 Alexander Toresson 2006-10-24 11:18:24 CEST
Note that the xfree86 4.3.0 that debian has is patched to include many of the patches and drivers in xfree86 4.5.0, if that might have any impact.
Comment 8 Olivier Fourdan editbugs 2006-10-24 17:34:10 CEST
From the other bug report you enterd (bug #2469), I understand that you do not have render available.

The problem shows when render is disabled, like with your install.
Comment 9 Olivier Fourdan editbugs 2006-10-24 19:28:27 CEST
Fixed with revision 23502. Please reopen if the problem remains with current SVN trunk.
Comment 10 Olivier Fourdan editbugs 2006-10-24 19:30:23 CEST
Copy Brendan since he was experiencing the issue.
Comment 11 Brendan Becker 2006-10-24 22:32:43 CEST
Apologies that I did not report my versions, I have recently checked out SVN again per the recommendation here and this problem appears to be fixed, thank you!

Bug #1617

Reported by:
Alexander Toresson
Reported on: 2006-03-27
Last modified on: 2009-07-14


Olivier Fourdan
CC List:
1 user



Additional information