! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Applets are very dark


Description Magnus Bergman 2019-10-31 00:34:12 CET
Created attachment 9167 
My panel with the applets systray, multiload, datetime and actions.

Since version 4.14 all applets based on GTK+ 3 are very dark or completely black. Applets based on GTK+ 2 (such as multiload-nandhp) are displayed correctly. Changing the background makes no difference. I suspect this relates to compositing which I don't use (since the window manager, Notion, that I'm using doesn't support it).
Comment 1 Simon Steinbeiss editbugs 2019-11-01 00:05:44 CET
Hi, this looks more like you're using a theme that doesn't properly support Gtk3 or something.
Which theme are you using?
Comment 2 Simon Steinbeiss editbugs 2019-11-01 00:07:21 CET
Oh also please check if things look ok with Adwaita. Thanks!
Comment 3 Magnus Bergman 2019-11-01 02:06:47 CET
Created attachment 9173 
The same problem with Adwaita

I was using a theme I made myself (and if someone can come up with a way to fix this in the theme I think it would be an acceptable solution I think). This is how it looks with Adwaita (the gray color around the panel comes from the theme of the window manager). Very similar but with a greenish tint, which might be some kind of clue?

I might also add that this happens on all three computers I've tried it on so far (using Intel and Nvidia graphics), so it's likely not graphics driver related. It's also not identical every time. On one computer it was very dark the first login after the update of xfce4-panel (similar to the screenshot or perhaps not quite as dark), but after a reboot the applets were completely black. On another computer they have (so far) only been completely black.
Comment 4 Simon Steinbeiss editbugs 2019-11-03 23:23:41 CET
That all sounds really odd...

Which distribution are you using?
Do you have anything like a custom gtk.css file in your home folder (e.g. ~/.config/gtk-3.0) that would override the standard theme?
Comment 5 brho 2019-11-04 15:52:41 CET
I have the same problem.  It's been like that for a while, though it got worse recently.  "worse" meaning the notification panel is also black now.  Previously, it was just a few of the other applets.

I don't have a gtk.css file in ~/.config/gtk-3.0.  I tried Adwaita, and that didn't help.  I also don't use compositing.
Comment 6 brho 2019-11-04 15:53:38 CET
*** Bug 16120 has been marked as a duplicate of this bug. ***
Comment 7 Simon Steinbeiss editbugs 2019-11-04 21:35:29 CET
@brho: Which distribution are you using?
Comment 8 Magnus Bergman 2019-11-05 01:12:57 CET
I'm using Gentoo. I had a few lines in gtk.css (to make the undershoot of scrolled windows transparent since it caused a bug some years ago). After removing this file the panel looks perfect!

But now to the strange part. I upgraded xfce on a forth computer. And on that computer this problem didn't show up. Yet it has the same fix in gtk.css. So I tried to reinstate gtk.css on the first computer to see if it was the cause of the problem. The panel still looks perfect, so apparently not. I can't think of a single thing that might have changed since it got working.

Now there are two computers left where the problem has been seen (which I don't have access to right now). I will check if I still can recreate the problem on them, and in that case check if the problem also occurs with other non-composing window managers. (Also I'm not confident that the problem is gone for good since it's been a bit random all along.)
Comment 9 Magnus Bergman 2019-11-05 19:07:57 CET
I found the key to the problem! (I wouldn't say solution as it doesn't fully explain all observations.) The darkness of the applets depends on the setting "leave-opacity". Setting this to 100 using xfce4-settings-editor (or not having it at all) and restarting the panel makes the applets always render correctly, as far as I can tell. But perhaps it doesn't fully solve the problem since something might cause this value to change. Maybe a new value is written to the config if the current one is invalid (which could explain why the appearance changed after a reboot)?

Anyway, it seems like version 3 of GTK (unlike version 2) supports opacity to some degree without compositing. So perhaps the opacity sliders should be enabled even then compositing isn't used, if it makes sense to implement old school transparency by grabbing the background? (But don't bother for my sake. I guess everyone who wants transparency uses a compositing window manager anyway.) Otherwise the setting should be completely ignored and perhaps the sliders could even be hidden (showing them disabled isn't very useful IMHO).
Comment 10 Simon Steinbeiss editbugs 2019-11-06 00:04:06 CET
The opacity sliders are still shown because there is an infobar informing the user of why opacity/transparency is not available incl a link to the dialog for enabling compositing.
The settings itself for enter/leave opacity are ignored - even if changed through xfconf-query or xfce4-settings-editor.
At least I couldn't reproduce it and am not sure how I would be able to...

Please let me know which steps to follow to get to the state you're currently in (if possible).
Comment 11 brho 2019-11-06 01:33:12 CET
That did the trick for me too.  I changed my enter and leave opacity from 0 to 100, restarted panel, and my panel icons are no longer blacked out.  Thanks!
Comment 12 Magnus Bergman 2019-11-06 02:33:48 CET
The problem can be reproduced like this:

1) Use a window manager without compositing (I've tested notion and twm).

2) Set "leave-opacity" to, say, 1.

3) Restart xfce4-panel.

Just to confirm I made a fresh install of Xubuntu 19 in VirtualBox and was able to reproduce it there too. However fewer applets seems to be affected. But at least the action buttons with appearance set to buttons are. (Note that the twm package provided by Ubuntu is buggy and doesn't run out of the box, setting LANG=C will work around the bug.)
Comment 13 Simon Steinbeiss editbugs 2019-11-06 09:14:38 CET
Interesting, I don't see this issue with Xfwm4 - can you reproduce it with Xfwm4?

Not sure what twm and notion do differently.
Comment 14 Magnus Bergman 2019-11-06 11:24:47 CET
For some reason I never thought of testing it with xfwm4. When doing so and turning off compositing I actually can reproduce the problem (still with the same fresh install of Xubuntu 19 in VirtualBox). Turning compositing on makes the problem go away, turning it off again and then restarting the panel makes it come back.
Comment 15 Git Bot editbugs 2020-05-28 02:17:49 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/xfce/xfce4-panel/-/issues/273.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #16106

Reported by:
Magnus Bergman
Reported on: 2019-10-31
Last modified on: 2020-05-28
Duplicates (1):
  • 16120 Panel applet areas blacked out


Simon Steinbeiss
CC List:
2 users




Additional information