! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
No window buttons
Window Buttons


Description Mikhail T. 2019-10-08 17:10:07 CEST
After the recent upgrades -- to 4.14.1 -- on three different computers (running FreeBSD of different versions), there are no longer any buttons shown in the "window buttons" applet.

Not for the open applications, not for the minimized ones. None. Indeed, a minimized app can only be restored by cycling through Alt-Tab -- and, sadly, some of them (like Citrix' wfica) do not appear on that list at all.

The separate "windows menu" applet seems to work properly, but the "windows buttons" is not showing anything.

I'm surprised, this hasn't been reported yet -- maybe, something is specific about my environment... For example, I have LANG set to Ukrainian (uk_UA.KOI8-U)...
Comment 1 Mikhail T. 2019-10-10 05:04:09 CEST
Just discovered, that my ~/.xsession-errors is full of messages like this:

(xfce4-panel:19957): libtasklist-CRITICAL **: 23:03:30.194: tasklist-widget.c:1155 (xfce_tasklist_size_allocate): expression 'area.height == tasklist->size' failed.

Why would this be?
Comment 2 Mikhail T. 2019-10-10 05:20:03 CEST
Created attachment 9105 
Relax check of area-size

First, I added a debugging printf to tasklist-widget.c, and found, that the area.height is 30, but tasklist->size is 48...

I then modified the code as attached, and got my buttons working again. Please, review and commit soonest. Thank you!
Comment 3 Simon Steinbeiss editbugs 2019-10-13 00:42:44 CEST
Could you either attach your panel config (feel free to export it with xfce4-panel-profiles) or describe the setup in a way so that I can reproduce the bug?
Thanks (also for debugging and attaching a patch)!
Comment 4 Mikhail T. 2019-10-13 06:04:09 CEST
There is nothing special about the panel -- it is horizontal, at the bottom of the 2nd of two screens. To the left is the application menu, followed by the application buttons. Then -- the workspace-switcher (four workspaces), then:

 . weather
 . snapshot
 . keyboard-switcher
 . clock

The panel seemed narrow after the upgrade, so I widened it up a little -- which means, the current settings aren't what I struggled with.

May it be, that area.height could some times be less than tasklist->size?
Comment 5 xfce 2019-10-31 03:14:25 CET
I'd like to confirm this bug: no window buttons. Problem remained after upgrading to 4.14. Oddly, this bug hit only one of four xfce users on this machine. After reading Mikhail's notes, we tried changing the Panel/Display/Measurements/Row size (pixels) slider, and the window buttons reappeared. They don't seem to disappear again even at the original setting of 48px.
Comment 6 xfce 2019-10-31 03:26:10 CET
Created attachment 9168 
xfce4 panel config

This is the config after the "size slider" fix. Not sure if it is helpful. Windows menu was added as a work around for broken window buttons while debugging.
Comment 7 xfce 2019-10-31 03:29:55 CET
Oh, and we also saw the .xsession-errors:

(xfce4-panel:12780): libtasklist-CRITICAL **: 22:00:46.579: tasklist-widget.c:1155 (xfce_tasklist_size_allocate): expression 'area.height == tasklist->size' failed.
Comment 8 Simon Steinbeiss editbugs 2019-11-04 10:03:52 CET
@Mikhail: So while I can see why the patch would fix your problem, I'm wondering why or how you're getting that problem in the first place.
Are you using a theme that is modifying the tasklist somehow? Or do you have any other instructions on how to reproduce?
(I'm open to pushing the patch to fix your issue, but I'd prefer to understand the root cause of this first.)
Comment 9 Mikhail T. 2019-11-04 13:59:20 CET
Sorry, I can't recall the exact series of events :( Could I have resized the entire bar down a little while using an earlier version of xfce4?

No, I'm not using any fancy theme...
Comment 10 Christof P. 2019-12-08 14:09:25 CET

I think i can provide you with some more info as i experienced the same problem too.

I got this problem while upgrading from xfce 4.12 on RHEL(installed from the EPEL repo) to xfce 4.14 on RHEL(compiled from source).

While upgrading to the new version(on a new machine, so not really upgrading), i use the (default.xml) panel config of the previous version.

After searching for about 2 days what caused this issue, i discovered that i also got the messages below when i launched the 3 commands below from within xfce
    pkill xfce4-panel
    setenv GTK_DEBUG "interactive xfce4-panel"
(xfce4-panel:8390): libtasklist-CRITICAL **: 12:41:02.988: tasklist-widget.c:1155 (xfce_tasklist_size_allocate): expression 'area.height == tasklist->size' failed.

As it seemed to have something to do with the size of the panel, i tried changing the "Row size(pixels) settings" from within xfce (right click on panel on top -> panel preferences -> go to panel 0(my top panel) -> change the "Row size(pixels) settings" slider which was on 48 by default), and suddenly the "window buttons" from the applications appeared.

After doing a diff between the original default.xml and the new default.xml(after moving the slider), i noticed that xfce added the 3 lines below on the bottom of the section for panel 0:

   <property name="mode" type="uint" value="0"/>
   <property name="length-adjust" type="bool" value="true"/>
   <property name="size" type="uint" value="30"/>

So this issue is reproducable by removing those lines again.

So i think the solution would be that when you start xfce 4.14 from the first time, it should add those 3 lines to the default.xml

If you need more info, please let me know.

Comment 11 Git Bot editbugs 2020-05-28 02:16:55 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/xfce/xfce4-panel/-/issues/267.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #16019

Reported by:
Mikhail T.
Reported on: 2019-10-08
Last modified on: 2020-05-28


Simon Steinbeiss
CC List:
3 users




Relax check of area-size (429 bytes, patch)
2019-10-10 05:20 CEST , Mikhail T.
no flags
xfce4 panel config (2.74 KB, text/xml)
2019-10-31 03:26 CET , xfce
no flags

Additional information