! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
No desktop after logging in


Description slumbergod 2019-09-08 22:12:02 CEST
I simply want to report my experiences with the Staging PPA for Bionic

xfwm4 (4.14) doesn't give me desktop after logging in. No Desktop icons. No Wallpaper. No panels.

Tried it on a clean install of Bionic (18.04.3) with Xubuntu updates installed and then the Staging PPA (i.e. no other software). Same thing. No desktop.

Roll xfwm4 back to an older version and logging in gives me the desktop back.
Comment 1 Olivier Fourdan editbugs 2019-09-09 08:44:37 CEST
Humm Ubuntu PPA... 

Are you using Intel?

If so, most likely a dupe of bug 15684 (same as bug 14475, bug 15741, bug 15765).

This is a bug in Mesa intel driver that shows when the build of Mesa has debug enabled, nothing xfwm4 can do about.

A workaround is to use xpresent for vblank.
Comment 2 mirh 2020-01-10 04:53:28 CET
So.. I am not OP, but whatever he has, I can tell you I'm running a GeForce 7100 with the last 304.137 nvidia closed drivers (and X.org 1.19 because yes, it's needed) and I'm getting the same. 
After three days of rolling back my whole system, finding it was xfwm4, fighting against the git tree and the tarballs being pretty messy with files at least around 4.13.2, and whatnot.. I could only come up with e07574d6e7a2dbaa08c3ba4765c6306073d9493e as the offending commit. 
... Which promptly made me realize I just needed to switch vblank mode as per bug 15325...

So anyway, stirred up by the lack of helpful people, I continued in my journey to see if perhaps some older version didn't have even GLX working... only to hit another roadblock when I saw that before 27238064f229fd4ecd9932ac52de46776fa1c7de you couldn't actually force vblank mode?
Or am I missing something, perhaps an environmental variable?

Regards and thanks for everything. 

p.s. it would really help if you could autobump issues older than a year, and close those that don't get an answer in like 6 months or something. It was really a feat to find this issue in a sea of decade old stale issues.
Comment 3 Olivier Fourdan editbugs 2020-01-10 09:15:56 CET
This bug here is about a bug in Mesa, so very unlikely that your problem is the same since you use the NVidia close source driver.

You just cannot pick a random bug, give no tangible data other than it worked without GL and complain that you don't get any help, it does not work like that.

Please open your own bug and provide the error (or better a backtrace) of xfwm4 when it fails to start on *your* setup.

Meanwhile, closing this bug.

*** This bug has been marked as a duplicate of bug 15684 ***
Comment 4 mirh 2020-01-10 20:45:34 CET
You had hypothesized it was a mesa error, OP didn't mention any specific hardware or software at all (besides xubuntu)
And I was criticizing users for lack of following up to bugs, not developers. 

But whatever, here it comes bug 16367

Bug #15948

Reported by:
Reported on: 2019-09-08
Last modified on: 2020-01-10


Olivier Fourdan
CC List:
1 user




Additional information