! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Plugin warning: Negative content width -3


Description yarosweet1 2019-07-13 18:23:05 CEST
Every time after boot .xsession-errors have

(wrapper-2.0:1312): Gtk-WARNING **: 19:17:14.107: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)

I understand that this is only harmless warning, but still. I don't know, maybe its not the plugin problem.
Comment 1 Andre Miranda editbugs 2019-07-16 19:01:35 CEST
It may be related (or not), but besides the reported warning, I'm getting the following for cpugraph, battery and systemload plugins:
gtk_widget_size_allocate(): attempt to allocate widget with width 32 and height -3

Playing with battery-plugin source and I have found that commenting out the call for gtk_container_set_border_width would make that warning go away, but I don't want to remove the plugin's border (in this case it's padding). I also tried gtk_widget_set_margin_*, no difference.

Looking at gtk's source[1], the message is printed when the widget allocation has any negative value, which makes me think the initial height would be 1, but we need to consider the border width, so 1 - 2 - 2 = -3 (top and bottom borders, each one is 2px when the panel is > 26px).
I tried a couple of things (gtk_widget_set_allocation, gtk_widget_realize, gtk_widget_size_allocate, removing child widgets) but nothing worked.
In the end I gave up, gtk is not really doing any favor with that message, it's more like a riddle than a heads up. Anyway, I hope this could be useful to anyone that may want to dive into this.

1 - https://gitlab.gnome.org/GNOME/gtk/blob/201327a49a368e766376905ef68e49f99aea63ad/gtk/gtkwidget.c#L6151
Comment 2 Git Bot editbugs 2020-05-23 00:40:31 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/-/issues/27.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #15711

Reported by:
Reported on: 2019-07-13
Last modified on: 2020-05-23


CC List:
1 user



Additional information