! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Menu does not close again when clicking on bottom area


Description Thomas Lange 2019-06-15 13:57:02 CEST
Current behavior:
The menu does not close when clicking directly on the label or icon with version 1.8.0.

Expected behavior:
The places plugin should behave as before in version 1.7.0 and like the application menu panel (4.12.2).
Clicking on the label or icon when the menu is open should hide it again.

This is a regression between 1.7.0 and 1.8.0, maybe due to the GTK3 port?
Comment 1 Andre Miranda editbugs 2019-06-17 01:06:32 CEST
Odd, it works as expected for me.
Comment 2 Thomas Lange 2019-06-17 19:00:48 CEST
Odd indeed, it seems to be related to the theme and panel size.
With Arc theme (https://github.com/NicoHood/arc-theme) and a size of 24x it is reproducible here.
Comment 3 Andre Miranda editbugs 2019-06-17 23:22:17 CEST
Created attachment 8645 

I tried Arc[1] on a 24px panel (deskbar and horizontal) with places-plugin 1.8.0, still no luck to reproduce this bug.

1 - https://www.archlinux.org/packages/community/any/arc-gtk-theme/
Comment 4 Thomas Lange 2019-06-19 00:10:54 CEST
Please try it with a panel on top where the menu opens downwards.
I am also using Arch by the way, so we can at least rule out the GTK3 version.
Something else I noticed now: It's not the icon or label, the whole area at the bottom (maybe 12px high) ignores the click.
Sorry if this bug report is indistinct. If you can't reproduce it now, I will try to record it like you did.
Comment 5 Andre Miranda editbugs 2019-06-19 22:42:21 CEST
I was finally able to reproduce this issue, but it depends on strictly following your settings:
- horizontal panel on top
- 24px size (the larger the harder to reproduce)
- Arc theme (I couldn't reproduce with Greybird, Adwaita, Materia and Numix)

This is also the case for xfce4-pulseaudio-plugin, so it leads me to think this is a bug in panel or Arc.
Comment 6 Michael Kogan 2019-08-13 09:42:44 CEST
I noticed this problem with xfce4-places-plugin and xfce4-pulseaudio-plugin as well. I am using Quogir GTK theme, 25px as panel height and the top of the screen as panel position. I think the area where the clicks are blocked is not related to the label but rather is the bottom half (or two third) of the plugin button.
Comment 7 Thomas Lange 2019-08-13 23:35:52 CEST
For Arch Linux all Xfce 4.14 packages are available already.
And as expected, the application menu in the panel behaves similar now.
So this is definitely not a bug in the places plugin.
I can also reproduce this issue with the Adwaita theme, but the unresponsive area for clicks is much smaller (maybe 7px high).
Comment 8 Andre Miranda editbugs 2019-08-14 04:56:54 CEST
Moving to panel as this is reproducible with more than one plugin.
Comment 9 Thomas Lange 2019-11-14 01:11:40 CET
Interestingly enough this is not reproducible with the "Clock" panel plugin.
Comment 10 Git Bot editbugs 2020-05-28 02:12:40 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/xfce/xfce4-panel/-/issues/237.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #15610

Reported by:
Thomas Lange
Reported on: 2019-06-15
Last modified on: 2020-05-28


Xfce Bug Triage
CC List:
2 users




places.gif (190.31 KB, image/gif)
2019-06-17 23:22 CEST , Andre Miranda
no flags

Additional information