gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPACKAGE_LOCALE_DIR=\"/usr/local/share/locale\" -I/usr/pkg/include/xfce4 -I/usr/pkg/xorg/include -I/usr/pkg/include/libxml2 -I/usr/pkg/include/gtk-2.0 -I/usr/pkg/lib/gtk-2.0/include -I/usr/pkg/include/pango-1.0 -I/usr/pkg/include/cairo -I/usr/pkg/include/glib/glib-2.0 -I/usr/pkg/lib/glib-2.0/include -I/usr/pkg/include/atk-1.0 -DXFCE_PANEL_THREADED=1 "-DXFCE_PANEL_LOCK()=gdk_threads_enter()" "-DXFCE_PANEL_UNLOCK()=gdk_threads_leave()" -g -O2 -MT libnetload_la-netload.lo -MD -MP -MF .deps/libnetload_la-netload.Tpo -c netload.c -fPIC -DPIC -o .libs/libnetload_la-netload.o In file included from net.h:21, from netload.c:22: os.h:201:2: #error "OS not supported" In file included from netload.c:22: net.h:56: error: field `prev_time' has incomplete type In file included from netload.c:22: net.h:86:2: #error "OS not supported" *** Error code 1 Reproducible: Always Steps to Reproduce: 1. 2. 3. diff ./net.c /home/bob/xfce4-netload-plugin-0.3.3/panel-plugin/net.c 49,51d48 < #elif __DragonFly__ < # include "wormulon/freebsd.h" < # include "wormulon/freebsd.c" diff ./net.h /home/bob/xfce4-netload-plugin-0.3.3/panel-plugin/net.h 65,67d64 < #elif __DragonFly__ < int watchif; < int dev_opened; diff ./os.h /home/bob/xfce4-netload-plugin-0.3.3/panel-plugin/os.h 75,98d74 < #elif __DragonFly__ /* D R A G O N F L Y */ < #include <stdio.h> < #include <stdlib.h> < #include <stdarg.h> < #include <unistd.h> < #include <string.h> < #include <time.h> < #include <ctype.h> < #include <signal.h> < #include <sys/param.h> < #include <sys/sysctl.h> < #include <sys/wait.h> < #include <sys/stat.h> < #include <sys/ioctl.h> < #include <sys/types.h> < #include <sys/socket.h> < #include <sys/time.h> < #include <netinet/in.h> < #include <net/if.h> < #include <net/if_media.h> < #include <net/if_mib.h> < #include <arpa/inet.h> < #include <net/ppp_layer/ppp_defs.h> < #include <net/ppp/if_ppp.h>
Thanks for reporting the bug. Should be fixed with SVN Revision 2247. Please reopen if not. PS: Please use the '-u' option for 'diff' next time. It's much more readable. Thanks.