! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
List view : first row too narrow


Description peggy.kutyla 2018-06-18 09:19:28 CEST
Created attachment 7794 

I've got list view as default option.
Every time I launch Thunar the first  row (ie file name) is only 3 letters wide.
If I change the width of the row, the setting isn't record.
Comment 1 alexxcons editbugs 2018-06-18 10:16:35 CEST
Hmm, works fine for me.
Which version of xfce4-settings-editor do you use ?
xfce4-settings-editor -V

What happens if you whipe out thunar/last-details-view-column-widths in the settings-editor?
Take care to first quit the thunar deamon with "thunar -q" !
Comment 2 peggy.kutyla 2018-06-18 15:18:06 CEST
xfce4-settings-editor 4.12.3 (Xfce 4.12)
Whipping thunar/last-details-view-column-widths in the settings-editor didn't solve anything . Here's the values if it is of any help :
Comment 3 alexxcons editbugs 2018-06-18 21:27:57 CEST
In order to reproduce, could you please as well give me your value of "last-details-view-column-order" ?

As well try the following:

thunar -q
Wipe "last-details-view-column-widths",  "last-details-view-visible-columns" and "last-details-view-column-order"

Expected result: Only "name" column displayed.

Here is my current setup, which works fine for me:




Does this setup work for you ?
Comment 4 peggy.kutyla 2018-06-19 07:26:35 CEST
last-details-view-column-order :

after wiping the 3 settings: I've got 4 rows : name, size, type,modified.
Seem to stick the way I resize it.

Finally nope.
I've added proprietary, group, permission and got the same behavior : couldn't resize name row.
After removing them one by one  via menu > display > configure rows , still the same : resizing name row don't stick.

Trying to use your settings don't work. Tried 3 times with 3 different results  : 2, 3 or 4 rows : name + modified ; name + size+ modified ; the 4 rows above
Comment 5 alexxcons editbugs 2018-06-19 23:24:32 CEST
Ok, finally I can reproduce.

What I can observe seems to be related to "thunar window is too small".

If I press all entries , so that there is minimum space between them as well prepare the thunar-window size accordingly, than after reopen, the name column looks like in your screenshot.

Making the window taller is not to remembered after reopen.
What you can do as quick-hack: Set the property "last-window-width" to e.g.1200 .. this will be recognized by thunar.

For a real fix I have to study the code.
Comment 6 alexxcons editbugs 2020-01-04 18:55:38 CET
Possibly duplicate of Bug #4801
Comment 7 Git Bot editbugs 2020-05-26 23:36:44 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/xfce/thunar/-/issues/203.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #14462

Reported by:
Reported on: 2018-06-18
Last modified on: 2020-05-26


Xfce Bug Triage
CC List:
4 users



first_row_thunar_181 (125.53 KB, image/png)
2018-06-18 09:19 CEST , peggy.kutyla
no flags

Additional information