! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
libical-3 support for orage


Description Mukundan Ragavan 2017-11-12 14:56:07 CET
libical version 3.x has been released and I can no longer build orage against libical on Fedora.

Here is the build log - https://koji.fedoraproject.org/koji/taskinfo?taskID=23079238

Please take a look. I will be able to test patches. Thanks.
Comment 1 Mukundan Ragavan 2017-11-14 23:35:19 CET
Created attachment 7438 
patch for building against libical 3.x

Patch from downstream bug report. Thanks to Milan Crha for the patch.
Comment 2 Stefan Seyfried 2018-03-03 20:36:03 CET
Created attachment 7625 
slightly different fix

This version has guards, so that older versions of libical still get the is_utc flag set (I think this is necessary for proper functioning)
Comment 3 ragaprasanth 2018-08-13 14:12:15 CEST
I too see the same error
Comment 4 Skunnyk editbugs 2019-10-27 18:39:58 CET
The orage project is not maintained anymore and has been archived. Closing bugs.

Bug #13997

Reported by:
Mukundan Ragavan
Reported on: 2017-11-12
Last modified on: 2019-10-27


CC List:
2 users




patch for building against libical 3.x (2.65 KB, patch)
2017-11-14 23:35 CET , Mukundan Ragavan
no flags
slightly different fix (2.88 KB, patch)
2018-03-03 20:36 CET , Stefan Seyfried
no flags

Additional information