! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Buttons randomly stop working. Rest of application works.


Description Peter B. 2017-10-31 18:28:34 CET
With Thunar (v.16.11) on a fresh install of Xubuntu 16.04.3 (64bit), I experience that the navigation buttons (left/right/up/home) stop working every now and then.
When I click them, they visually change their press-state - but nothing happens.

This stays until:
  * I close / reopen thunar.
  * I change to another folder. Either by clicking on one in the GUI or entering a different path in the address field.

I'll check if it only happens when accessing network shares (cifs/Samba), but I cannot confirm this yet.
Comment 1 Andre Miranda editbugs 2017-11-01 04:13:46 CET
If you're brave enough, try thunar from git master or await the next development release (1.7.0), it's gtk3-based, maybe the problem is gone (maybe not).
Comment 2 Peter B. 2017-11-01 11:03:10 CET
Is there a repository for that - or would I have to build my own?
Comment 3 Andre Miranda editbugs 2017-11-02 03:34:41 CET
Not yet, I'm about to release 1.7.0 (development release), maybe next week, hopefully someone will provide a PPA for that version.
If you're curious enough, you can try xfce-test (uses docker) or spin up an Arch (or Manjaro) VM to use the thunar-git package from AUR.
Meanwhile, if you're able to collect more info about the issue it would be very helpful. I'm using thunar from git and tried lots of things to reproduce this bug to no avail. Are you just click on the arrow buttons with the left button, or are you dragging and right-clicking? Is there a pattern? How hard is it reproduce this on your side?
Comment 4 Peter B. 2017-11-02 09:23:33 CET
Roger that :)

I'll try to collect more infos about this issue.
Still looking to find a pattern.
It also happened with local drives yesterday, and it happens at least once in about 2 hours.
Just clicking the buttons. No dragging/right-clicking (that I'm aware of).

btw: Correction of my above statement:
Buttons resume normal functionality *only* when changing the folder in the address line.
*not* by clicking on a folder in the GUI.

When encountering problems with GUI applications I usually try starting them from the shell, so I see their "background" output in the console. Thunar detaches from the shell though :(

Is there any way to run thunar in something like debug-mode?
Currently swamped with other work, but I'll can try setting up a VM to test thunar-git.
If I do, I'll let you know.

Thanks for your help!
Comment 5 Peter B. 2017-11-02 12:35:17 CET
Noticed something very interesting just now:
I waited a few seconds, then the buttons worked again.
Comment 6 Peter B. 2017-11-02 18:36:38 CET
I've tried switching "Location Selector" from "Toolbar" to "Pathbar" style to see what happens:
The pathbar-buttons exhibit the same behavior.

It seems like Thunar is performing some kind of action in the background that causes it to "wait". Any ideas what this could be?
Comment 7 Andre Miranda editbugs 2017-11-03 04:06:30 CET
Thunar doesn't detach, it's already running in background, you may pkill -i thunar to be able to run thunar in a terminal and get its output.
The symptoms are very likely to be caused by the application hanging.
I just noticed that you selected the 1.6.11 version for this bug report, can you try to update to 1.6.12? Bug #13481 was fixed in that release, maybe it's related somehow.
Comment 8 Peter B. 2017-11-03 17:47:40 CET
I've killed (*) the thunar process this morning and started it from the shell.
Result: The issue did not occur for a whole day. Hm...

(*) pkill does not have a "-i" option, but I assume you meant "case insensitive" (like "grep -i"), since the thunar process is "Thunar".
Comment 9 Peter B. 2017-11-03 17:49:30 CET
btw, here are error messages that appeared (although I couldn't link them to this issue):

(thunar:21642): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Comment 10 Andre Miranda editbugs 2017-11-04 00:30:36 CET
I don't think that this error message is related, if you're using 1.6.11 (you didn't answer me) this message was fixed in 1.6.12 IIRC.

* pkill does have a case insensitive option, using Arch here, but even the version present in Ubuntu 16.10 provides this option.
Comment 11 alexxcons editbugs 2020-05-11 01:00:19 CEST
Did you take a try for thunar 1.8.x meanwhile ? Can you still reproduce the bug there ?
(Because for me it works fine there)
Comment 12 Peter B. 2020-05-11 23:08:45 CEST
@alexxcons: I haven't been able to try either v1.7 nor v1.8 since this is my office PC and I'm bound to xubuntu LTS versions. I do have updated to Thunar to v1.6.15 due to updating to Xubuntu 18.04.3 recently.

I haven't experienced it "yet", but I'm only using this version for a few days now.

Sorry for not being able to report on the latest versions :(
And thank you for your time!

I know this is XFCE not (x)ubuntu bug tracking, but what would be your suggestions for properly installing e.g. Thunar v1.8.x for testing?
Comment 13 alexxcons editbugs 2020-05-12 22:33:45 CEST
If you like, you can try building thunar from source (Best use the 1.8.14 tag):

(If you have root/sudo on your system, you can install it as well)
Comment 14 Peter B. 2020-05-18 13:40:23 CEST
Seems this issue can be closed:
I haven't experienced it anymore since updating to Xubuntu 18.04.

Thank you very much! :)

Bug #13969

Reported by:
Peter B.
Reported on: 2017-10-31
Last modified on: 2020-05-18


Xfce Bug Triage
CC List:
4 users




Additional information