! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
IMAP passwords with " special character fail to authenticate


Description Adam Bolte 2015-12-28 11:25:54 CET
I had a long password with many special characters. One of those characters was the double-quote character ", and mailwatch (as packaged in Debian Jessie) was unable to authenticate to the server.

Next, I tried rolling my own package using the latest git master HEAD (commit d046d61ea277ad5432dc33130d6efd6d6dd8f317), re-added and reconfigured the applet and tried again. Still no luck authenticating.

Lastly, I removed the " character from my password (leaving all other characters including special characters in place), and finally mailwatch started working.
Comment 1 Git Bot editbugs 2020-05-24 00:44:47 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/panel-plugins/xfce4-mailwatch-plugin/-/issues/41.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #12382

Reported by:
Adam Bolte
Reported on: 2015-12-28
Last modified on: 2020-05-24


Florian Rivoal
CC List:
1 user



Additional information