! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Thunar (1.6.10) crashing when moving files by drag and drop


Description kouros17 2015-11-19 13:09:12 CET
I'm using manjaro 15.09 xfce and thunar (1.6.10) crashing when moving files by drag and drop especially from desktop to thunar, although files normally move to the new folder.
Opening thunar by terminal loading normally aswell without more info.
Comment 1 peggy.kutyla 2015-11-22 12:17:50 CET
look's like https://bbs.archlinux.org/viewtopic.php?id=203663
seems related to glib2 2,46
Comment 2 afg984 2015-12-07 20:36:47 CET
It also happens on my machine: (Arch Linux x64, thunar 1.6.10),
but upon moving files with Ctrl-X, Ctrl-V.

$ thunar

(thunar:2968): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' failed

(thunar:2968): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(thunar:2968): thunarx-CRITICAL **: thunarx_file_info_changed: assertion 'THUNARX_IS_FILE_INFO (file_info)' failed

(thunar:2968): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' failed
[1]    2968 segmentation fault (core dumped)  thunar

thunar[2968]: segfault at 3 ip 00007f270622988d sp 00007ffcfe8cdd38 error 4 in libgobject-2.0.so.0.4600.2[7f27061f5000+51000]
Comment 3 afg984 2015-12-07 20:43:27 CET
maybe related to Bug 12260 and Bug 12264?
Comment 4 slumbergod 2016-04-27 01:46:55 CEST
Someone suggested using the "patched" version but isn't that the one that comes in the repos for xubuntu 16.04? If it is patched it isn't making any difference for me. Crash Crash Crash
Comment 5 slumbergod 2016-04-27 01:55:50 CEST
In Arch discussions someone said they just compiled 1.6.4-2 and that solved their problems. PLEASE can the devs try compiling an older version of thunar and putting that in the repos.

An older version that doesn't crash is preferrable to one that crashes on almost every file transaction.
Comment 6 Mikhail Kurinnoi 2016-05-07 22:11:09 CEST
Same here with thunar 1.6.10. I can copy and rename files/folders without any issues, but have thunar crashing when moving files/folders by drag and drop OR cut and past files/folders between thunar windows.


Thunar[65066]: segfault at 2 ip 00006364d1021403 sp 000073142d1460c0 error 4 in libgobject-2.0.so.0.4600.2[6364d0fe4000+5e000]

grsecurity2 log:

traps: Thunar[64134] general protection ip:64f559df441c sp:746c41636b30 error:0 in libc-2.22.so[64f559d76000+1a1000]
grsec: Segmentation fault occurred at            (nil) in /usr/bin/thunar[Thunar:64134] uid/euid:1000/1000 gid/egid:1000/1000, parent /sbin/init[init:1] uid/euid:0/0 gid/egid:0/0

Also please note, I can't reproduce this bug with "debug" option. Have no idea what is wrong with that, but if I use thunar compiled on my Gentoo with "debug" option - all works like a charm. So, I can't provide any more debug-related info...
Comment 7 slumbergod 2016-05-07 23:41:47 CEST
Michael, try replacing the thunar binary with the one Martin compiled using a single patch. It solved the problems for some of us.
Comment 8 Mikhail Kurinnoi 2016-05-08 00:06:35 CEST
Thanks for point me on that thread.
I checked patch from 41 comment https://bugzilla.xfce.org/show_bug.cgi?id=12264#c41, this fix the drag-and-drop issue for me.
Comment 9 Robert 2016-08-06 10:43:21 CEST
Just to add another data point: the crash happens to me on Xubuntu 16.04 64 bit:

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.1 LTS
Release:	16.04
Codename:	xenial

$ uname -a
Linux babelfish 4.4.0-31-generic #50-Ubuntu SMP Wed Jul 13 00:07:12 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

$ dmesg | fgrep -i thunar
[ 6081.753099] Thunar[18104]: segfault at 4 ip 00007f967cc717ed sp 00007fffcc064a98 error 4 in libgobject-2.0.so.0.4800.1[7f967cc3d000+52000]

When I drag an object from the desktop and move it to a Thunar window, the file is moved as expected but the window disappears and said error occurs.  This does not seem to happen when moving from one Thunar window to another.

But: this does not happen always.  First, I thought it happens only when moving to my home directory opened in a window but even then it does not always happen.
Comment 10 alexxcons editbugs 2017-12-15 22:20:30 CET
As far as I can tell, the patch which fixes the issue was pushed in:
And should be inside Thunar 1.6.11-0ubuntu1

If I am wrong, please feel free to reopen the bug !

Bug #12320

Reported by:
Reported on: 2015-11-19
Last modified on: 2017-12-15


Xfce Bug Triage
CC List:
11 users




Additional information