! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Dropdown terminal window turns invisible, still captures mouse clicks


Description Gabor Csertan 2015-06-01 16:21:36 CEST
With compositing turned on, all dropdown-style terminals I tried (tilda, guake, yakuake) have the same problem. After some use their window doesn't render anymore, but it still captures mouse clicks and can't be hidden. Ther eare no error messages if ran from another terminal. The guake tray icon is still responsive and I can close the application, that's why I think it's an xfwm bug.

I tested guake with compositing off and with compton, the bug didn't occur after a day of usage.

Steps to reproduce:
Uncertain, it usually happens after 10-30 minutes of usage (a couple of dozen show/hide actions)

Build Date & Hardware:
Uncertain, the bug already existed about 2 months ago, it persists in 4.12.3.
Tested on HP Pavilion 15t Touch (Intel HD 5500 videocard) with Manjaro and custom desktop PC (Radeon HD7770 videocard) with Arch, 64 bit version of both distributions.
Comment 1 Olivier Fourdan editbugs 2015-06-01 16:35:46 CEST
- If you disable and re-enable the compositor in xfwm4, does the window show again?
- Is it a regression in 4.12, ie did the same occur in 4.10?
Comment 2 Gabor Csertan 2015-06-02 08:54:35 CEST
If I disable compositing the window turns black, if I turn it back on it goes invisible again. In either state it doesn't process keyboard input.

I didn't use a dropdown terminal in 4.10 so I don't know if the bug occured in that version.
Comment 3 Gabor Csertan 2015-06-04 18:08:47 CEST
It happened again today with compton. I'll test it without compsiting tomorrow and report back.
Comment 4 Olivier Fourdan editbugs 2015-06-04 18:12:19 CEST
(In reply to Gabor Csertan from comment #3)
> It happened again today with compton. I'll test it without compsiting
> tomorrow and report back.

Which wold rule out xfce compositor.

BTW, I've been running Guake for the past few days and got no hang so far. The app crashed on the first day though.

I am still not entirely convinced this is a bug in xfce.
Comment 5 Thaddaeus Tintenfisch editbugs 2015-06-05 09:45:37 CEST
There is an older report which describes the same problem (bug 10083).
Comment 6 Gabor Csertan 2015-06-05 10:13:50 CEST
True, but from since it happens with at least 3 other apps it's not an xfce4-terminal bug.
Comment 7 Olivier Fourdan editbugs 2015-06-05 10:16:27 CEST
(In reply to Gabor Csertan from comment #6)
> True, but from since it happens with at least 3 other apps it's not an
> xfce4-terminal bug.

OT, but since when xfce4-terminal has a drop down option? I see no such thing here.
Comment 8 Gabor Csertan 2015-06-05 10:17:47 CEST
It pops up for me when I press Ctrl-Alt-T, I don't know if it's an xfce feature or a Manjaro specific binding.
Comment 9 Hg 2019-12-12 19:02:31 CET
This issue still seems to happen: https://github.com/Guake/guake/issues/1666
Comment 10 Git Bot editbugs 2020-05-29 12:05:39 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/xfce/xfwm4/-/issues/182.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #11954

Reported by:
Gabor Csertan
Reported on: 2015-06-01
Last modified on: 2020-05-29


Olivier Fourdan
CC List:
2 users




Additional information