! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
GTK3/Gnome apps do not honor reverse scroll setting


Description boennhoff 2015-03-15 14:08:32 CET
I have a Thinkpad T440s including a Synaptics Clickpad and am used to the reversed-two-finger-scrolling. I just switched from Gnome 3 back to good old XFCE 4.12 -- I am on Arch Linux, FYI.

So, one of the first things was to set up this same natural (reversed) scroll behavior in XFCE too, through settings in "Mouse and Touchpad", which i only did for the Synaptics device. But this setting is not taken into account in any Gnome/GTK3 apps I tested it with: nautilus, gedit, evince, ...

To sum up: If I now swipe two fingers up on my touchpad in xfce-terminal it scrolls down (correct), and if i do the same in evince it scrolls up (incorrect).

I tried to solve the issue myself, but could not find anything useful, since most of the problems are related to older XFCE releases, or the general inability to reverse the scroll direction. I tried some hacks within .Xmodmap (pointer) without success.

I have to add, that this was not a problem while using Gnome. There the set up scroll direction was honored in all applications (and is still setup there, i did not change anything here before switching to XFCE).
Comment 1 Thaddaeus Tintenfisch editbugs 2015-03-15 14:44:31 CET
Duplicate of bug 11193.

*** This bug has been marked as a duplicate of bug 11193 ***

Bug #11702

Reported by:
Reported on: 2015-03-15
Last modified on: 2015-03-15


Olivier Fourdan
CC List:
2 users




Additional information