! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
xfwm4 4.11.2: Can't fully alt-tab with wine "explorer" app


Description brho 2014-08-31 23:01:12 CEST
Hi - 

With xfwm4 version 4.11.2, but not version 4.11.1, I can't alt-tab out of a full-screen wine application, launched with explorer.  The application changes, but wine remains on top.  For example:

$ wine explorer /desktop=0,1920x1200

Normally, I launch games with a line similar to that, where the actual application is listed after the desktop settings.  The above line is sufficient to produce the bug.

When I am in the full-screen wine app (just a blue background, maybe with a desktop icon in the example), alt-tab brings up the selection panel and actually changes to another application.  The other application selected, for instance a terminal, receives keyboard input.  But it is not drawn, and all I see is the wine application, which also seems to control the mouse.

I tried various Focus settings, but none of them worked.

I dropped into the main console, via ctrl-alt-f1, and saw empty messages from xwfm4, such as "xfwm4-Message: (nil), once for each alt-tab attempt.

I reverted to 4.11.1 and the problem went away, meaning alt-tabbing works as expected (visually as well as keyboard control).

I'm running:
- wine-1.7.21
- 3.14.0-gentoo, amd64
- fglrx driver on an ATI HD4850

I can file the bug with gentoo also, if you'd like, but figured I'd come directly here.  If you can't reproduce the problem easily and have patches for me to try, I'd be happy to try them out.

Comment 1 brho 2014-09-02 17:04:32 CEST
Might be related to:


Though I was able to ALT-TAB out of full screen wine apps that were not launched with the "explorer" / virtual desktop.  Btw, the problem with not using the "explorer" is that when ALT-TABbing back to the wine app, the desktop's panels remain above the app.
Comment 2 brho 2015-07-06 01:06:37 CEST
Fixed in xfwm4 version 4.12.3

*** This bug has been marked as a duplicate of bug 11120 ***

Bug #11125

Reported by:
Reported on: 2014-08-31
Last modified on: 2015-07-06


Olivier Fourdan
CC List:
0 users




Additional information