! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Can't open up "Quit" Menu


Description Andy Kissner 2005-08-13 16:22:18 CEST
Whenever I try to quit XFCE, nothing appears on screen. This happens when using
ctrl-alt-delete as well...

Reproducible: Always
Steps to Reproduce:
1. Press Ctrl-Alt-Del
2. Goto the XFCE Menu, and select Quit 

Actual Results:  

Expected Results:  
The little logout menu should have appeared.

Xfce 4 Desktop Environment
version 4.2.0 (Xfce 4.2)

Comment 1 ebuswell 2006-11-14 21:52:45 CET
This happens on my setup as well.

The issue:

xfce4 session tries to create session save names like "user@host:0" which works fine so long as the underlying fs accepts colons.  VFAT, which I use for my home directory doesn't.  When xfce4-session can't write to this file, AFAIK, it hangs.  Clicking on the panel logout button gives "Quit XFCE Panel", and right-clicking on the desktop or using the main menu to logout gives no result whatsoever.  The only way to logout is to kill xfce4-session.

Solution: s/:/_/g

Workaround: switch home directory to ext3 (lame).
Comment 2 sardion 2007-02-24 03:44:52 CET
I have the same issue, not 100% of the time but about 75%.

I am using ext3 and not vfat, so the : issue cannot be the whole story.

Running xfce4-session-logout by hand does not work either, no output, no behavior at all.

Preliminary attempts to debug show the error is not in the xfce4-session-logout code, but I haven't been able to locate where the error is.
Comment 3 sardion 2007-02-24 03:46:11 CET
ps. I am using xfce 4.4.0  (xubuntu feisty).
Comment 4 Kari Aliranta 2007-05-12 14:29:44 CEST
Yup, definitely found in Xubuntu 7.04, too. See:

Comment 5 Alex V. Myltsev 2007-09-04 13:34:13 CEST
Still reproducible on 4.4.1 (ALT Linux / i686), not 100% of the time too.
Comment 6 Kari Aliranta 2007-11-05 18:34:48 CET
Yup, I can confirm that this bug still affects Xfce 4.4.1 on Xubuntu 7.10 (Gutsy). Also, for me, the bug is still manifested only when trying to initiate the Quit-dialog from Xfce-menu - Alt-F4 works fine. 

(P.S. The "Version" field should probably be changed to 4.4.1, shouldn't it?)
Comment 7 Nicolas Cortot 2007-11-18 08:51:14 CET
I found this bug with xfce4-session-4.4.1 on Gentoo (XFCE 4.4.1, kernel 2.6.22, GTK+ 2.10.14, glib 2.12.7).

While I seriously doubt this is the best solution, adding a g_usleep(10000) before the call to g_idle_add_full in xfce4-session-logout/main.c:115 solved the problem for me. Or at least it reduced the failure rate from about 50% to less than 0.5%).
Comment 8 Daniel Butzu 2007-12-08 23:33:15 CET
Using xfce4-session 4.4.1 on Gentoo. Quit almost never works from the Xfce Menu, but it always works from the Quit/Lock panel plugin.
Comment 9 Nick Schermer editbugs 2010-11-15 23:42:07 CET
Reassign to xfce-bugs@xfce.org.
Comment 10 Jérôme Guelfucci editbugs 2011-02-06 00:05:59 CET
Can anyone still reproduce this with Xfce 4.8?
Comment 11 MotherDawg 2012-05-23 20:40:11 CEST
Yup !

I have tried to set the logout to panel button to anything and the only thing it does is it logs me out to GDM. I have to shut down from there.

There is a caveat in my setup : Fedora 17 BETA.

I about to try to take the Panel button out and rm my .cache and .session.
I also have the xkb panel applet that reset to nothing. I have read the work around in 6657 and I'm testing it. Because of systemd, I have to re-learn everything to go start in single user.

Here is some of my setup :
Linux Think.Dawg 3.3.4-5.fc17.i686 #1 SMP Mon May 7 17:45:26 UTC 2012 i686 i686 i386 GNU/Linux

Installed Xfce components :
gtk-xfce-engine.i686               2.99.0-2.fc17                @anaconda-0     
im-chooser-xfce.i686                    installed       
imsettings-xfce.i686               1.2.9-1.fc17                 installed       
libxfce4ui.i686                    4.8.1-2.fc17                 @anaconda-0     
libxfce4util.i686                  4.8.2-2.fc17                 @anaconda-0     
xfce-utils.i686                    4.8.3-6.fc17                 @anaconda-0     
xfce4-appfinder.i686               4.9.3-2.fc17                 @anaconda-0     
xfce4-doc.noarch                   4.8.3-6.fc17                 @anaconda-0     
xfce4-icon-theme.noarch            4.4.3-6.fc17                 @anaconda-0     
xfce4-mixer.i686                   4.8.0-3.fc17                 @anaconda-0     
xfce4-panel.i686                   4.8.6-4.fc17                 @anaconda-0     
xfce4-power-manager.i686           1.0.10-3.fc17                @anaconda-0     
xfce4-session.i686                 4.8.3-1.fc17                 @anaconda-0     
xfce4-session-engines.i686         4.8.3-1.fc17                 @anaconda-0     
xfce4-settings.i686                4.8.3-4.fc17                 @anaconda-0     
xfce4-taskmanager.i686             1.0.0-4.fc17                 @fedora         
xfce4-xkb-plugin.i686                   @fedora         

Will post after a few reboot
Comment 12 MotherDawg 2012-05-23 23:16:11 CEST
I'm Back...

Figured out that Xfce clears out the session directory...
RMed the .cache but to no avail. All Action buttons; main menu, panel applet and Alt-F4 instantly logs me out to the gdm login screen. LXDE gives me the dialog menu but that shell is too limited for me.

My T42 ThinkPad was a happy camper with Gnome2 on a Fedora13. After being fed up because it was passed its end of life, I installed F16 with Gnome3 to have it end up in fallback mode... what a downer! Then jumped on F17 beta to get the software rendering feature... to no avail. Even tried Cinnamon. It's been more than a month since I had a stable shell.

Gnome3 sucks Big Time. I need to work not play.

So I re-installed with Xfce and I can now work but slight bugs here and there.

Now... systemd and firewalled... wow, awesome new daemons. Fun.

Any help, pointers would be much appreciated. Thank you.
Comment 13 MotherDawg 2012-06-08 18:24:57 CEST
I'm still stuck with this.
I removed all applet kept an empty panel, Add just the Action Button... no Quit dialog box just instant log out.

Where is the applet setting file so I can mod it manually ?

My present work around :
# uptime
12:24:05 up 9 days, 21:31,  2 users,  load average: 0.36, 0.52, 0.66


Any one ???
Comment 14 MotherDawg 2012-06-12 00:36:23 CEST
Since I had a lot of return here... I hacked at it and I DID figured it out:

I figured out that I AM a Dumb Kumquat!

If I actually would set the "Prompt on logout" option to ON in the "Session and Startup" app... I would get a logout dialog box...

Happy Happy Joy joy, Happy Happy Joy joy, Happy Happy Joy joy, I did not open a new bug for it.

I feel like a newb.

*** Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. -- Albert Einstein
Comment 15 Simon Steinbeiss editbugs 2013-11-27 10:47:45 CET
This issue seems resolved.

Bug #1109

Reported by:
Andy Kissner
Reported on: 2005-08-13
Last modified on: 2013-11-27


Xfce Bug Triage
CC List:
10 users



Additional information