! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
No mechanism to effectively set alternate window manager


Description Michael Mol 2014-02-10 11:49:01 CET
I desired to use 'awesome' as my window manager, but have the rest of the XFCE4 desktop environment available. After fairly extensive searching, I wasn't able to find any "correct" way to change the window manager.

Mechanisms I found mentioned and tried:

Attempt: Run alternate window manager with --replace parameter, save session. ( https://wiki.archlinux.org/index.php/Xfce#Replacing_the_native_window_manager)
Result: awesome doesn't support --replace parameter, so sent SIGTERM. xfwm4 restarts until fifth kill. Session save did not take.

Attempt: Use "xfconf-query -c xfce4-session -p /sessions/Failsafe/Client0_Command -t string -s "awesome" -a" as found documented here: http://askubuntu.com/questions/169880/how-can-i-change-the-xfce-window-manager-to-awesome
Result: No discernible effect.

Attempt: Rename and replace /usr/bin/xfwm4 with desired window manager.
Result: This is a profoundly bad idea, since one is stepping on the system package manager's territory. However, this ultimately worked: ln -s /usr/bin/awesome /usr/local/bin/xfwm4

So, I now have my desired window management behaviors and keyboard shortcuts, though the system fought me a great deal for it.

It...works. Not terribly well. Here are the quirks I encounter under operation:

1) Anything started by XFCE's session manager does not appear in the notification applet; if I have applications I need to have access to the notification area (my email, nm-applet, pidgin, dropbox), I have to start them manually. I'm sure there's something that could be done in XFCE, architecturally, to improve this particular situation.

2) Logging out from XFCE via the application menu seems to have a dependency on xfwm4 that has to time out before logout proceeds. First attempt appears to do nothing, but other applications refuse to launch. Immediate subsequent attempts complain that there is a session operation already in play. Eventually, it will proceed with the commanded logout/reboot/shutdown operation.

3) "Run Program" app launcher takes a long time to appear when launched. I'm still able to use Awesome's Mod4+r to run commands, even if I can't see the command I'm typing, so this works...OK for me.
Comment 1 Edoardo Maria Elidoro 2014-02-10 20:31:50 CET
I don't know if it works with Awesome, but there's this (much simpler) way[¹] that works both with Gala, Compiz and Kwin.

[¹] http://ohheyitslou.blogspot.it/2013/06/how-to-use-gala-window-manger-with-xfce.html
Comment 2 Simon Steinbeiss editbugs 2015-01-31 14:59:47 CET
I don't think this is something we can fix in xfce4-settings at all, and to be honest, if you wanna use a custom setup, you're on your own.

This seems like a thread that is viable for a forum or support, not a bugreport.

Bug #10680

Reported by:
Michael Mol
Reported on: 2014-02-10
Last modified on: 2015-01-31


Nick Schermer
CC List:
5 users




Additional information