! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
xfce4-popup-notes does not work when using panel plugin


Description Tomas 2013-07-03 21:28:03 CEST
It would be nice with the possibility to set a "global hotkey", which would trigger the notes, like left-clicking the panel icon.

This, combined with "always on top", would make a nice, keyboard-only solution to note taking.

I would personally use Super+N ...
Comment 1 Mike Massonnet editbugs 2013-07-03 21:31:08 CEST
just bind a shortcut (xfce4-keyboard-settings) to xfce4-popup-notes

 - m
Comment 2 Tomas 2013-07-03 21:47:47 CEST
This is not doable when notes is running as a panel plugin. It works when it's a tray-icon.
But thanks, I guess it'll do fine for me :-)
Comment 3 Mike Massonnet editbugs 2013-07-06 12:28:33 CEST
than it sounds like a bug.

what version of xfce4-notes do you currently have?

and you tried to run xfce4-popup-notes, not xfce4-notes, right?
Comment 4 Roland Kaufmann 2015-08-07 11:19:58 CEST
This bug pertains at least to xfce4-notes version 1.7.7-2ubuntu1 (I haven't been able to check if it is fixed in 1.8).

If `xfce4-notes &` is executed from the command-line, then `xfce4-popup-notes --show-hide` shows the notes, but does not hide them.

If it has been launched from the panel plugin and the "Hide notes from taskbar" option is unchecked, then `xfce4-popup-notes --show-hide` shows the notes, but doesn't hide them.

If it has been launched from the panel plugin and the option is checked, then `xfce4-popup-notes --show-hide` neither shows nor hides the notes.
Comment 5 Anders Kusk 2015-09-13 19:47:10 CEST
I have the same error. I can show, but not hide the notes.

xfce4-notes-plugin 1.8.1-1 in Arch Linux.
Comment 6 Git Bot editbugs 2020-05-23 00:26:06 CEST
-- GitLab Migration Automatic Message --

This bug has been migrated to xfce.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.xfce.org/panel-plugins/xfce4-notes-plugin/-/issues/18.

Please create an account or use an existing account on one of our supported OAuth providers. 

If you want to fork to submit patches and merge requests please continue reading here: https://docs.xfce.org/contribute/dev/git/start#gitlab_forks_and_merge_requests

Also feel free to reach out to us on the mailing list https://mail.xfce.org/mailman/listinfo/xfce4-dev

Bug #10214

Reported by:
Reported on: 2013-07-03
Last modified on: 2020-05-23


Mike Massonnet
CC List:
2 users




Additional information