! Please note that this is a snapshot of our old Bugzilla server, which is read only since May 29, 2020. Please go to gitlab.xfce.org for our new server !
Parole needs H.264


Description srkk5461 2018-07-09 18:52:54 CEST
Created attachment 7824 

Is saying that Parole needs H.264 decoder to play this video

what I should do?
help me please.
Comment 1 vc 2018-07-26 13:44:24 CEST
I have this problem too.
Happens when opening MTS files. Says needs H.264 codec and offers to install automatically. Clicking button that offers to install the codecs does nothing. Played fine with Parole on another machine. Probably was an earlier version of Parole?
I think I have the codecs installed. VLC plays the MTS files ok.
Maybe Parole can't access or read the installed codec??
Comment 2 Andre Miranda editbugs 2018-08-23 03:20:38 CEST
*** Bug 14623 has been marked as a duplicate of this bug. ***
Comment 3 Andre Miranda editbugs 2018-08-23 03:42:21 CEST
I was able to reproduce this bug with a video sample from http://www.lehman.edu/faculty/hoffmann/itc/techteach/video/Video_samples.html and removing gst-plugins-ugly beforehand (Arch Linux).

Inspecting the source, I found the problem here https://git.xfce.org/apps/parole/tree/src/gst/parole-gst.c?id=5ae8b124dba5e203810c08860468a33bdaaa0721#n1433 the return (GstInstallPluginsReturn) of gst_install_plugins_async is not check, in my case it returns GST_INSTALL_PLUGINS_HELPER_MISSING.

The user has to be notified about failures, maybe via a error dialog or infobar.

Even the callback for that function doesn't tell the user its result:
Comment 4 Git Bot editbugs 2018-08-25 12:21:26 CEST
Sean Davis referenced this bugreport in commit 171d87ad3210bd1f3e1a42cc6df862e8ea4679b6

Catch GST_INSTALL_PLUGINS_HELPER_MISSING and notify the user (bug #14529)

Comment 5 Sean Davis editbugs 2018-08-25 12:22:03 CEST
@Andre, can you test the above commit and let me know if this resolves the issue for you?
Comment 6 Andre Miranda editbugs 2018-08-25 23:08:58 CEST
Created attachment 7912 
fix patch

@Sean, unfortunately that commit doesn't work as intended, the result GST_INSTALL_PLUGINS_HELPER_MISSING is not passed to the callback, it returns from gst_install_plugins_async.

See the attached patch.
Comment 7 Git Bot editbugs 2018-09-01 00:39:41 CEST
Sean Davis referenced this bugreport in commit f756317140942976439292201e6596042952ce55

Correctly handle missing plugins helper (thanks Andre) (bug 14529)

Comment 8 Sean Davis editbugs 2018-09-01 00:40:28 CEST
@Andre, I made a small adjustment to your patch (== vs =), please test the above commit before I call this one done. Thanks!
Comment 9 Andre Miranda editbugs 2018-09-01 02:55:47 CEST
Yes, it works now, thanks. Good catch, I didn't notice the broken comparison.
Before we close, I think users will complain about this message too. How does one make a plugin installer available? If it's harder than figuring out the right package to install, then it would be better to not even try to install.

Sorry for proposing a fix and then proposing to change that, I tried put some sense in the code, but from a user perspective, it is as frustrating as before :/
Comment 10 Sean Davis editbugs 2018-09-01 22:07:21 CEST
I think at this point, it should be left to the forums or documentation (or even bug reports to get maintainers to add the missing package). The answer will vary for every setup and distribution.

I'd recommend documenting solutions that we do know to http://docs.xfce.org/apps/parole/start
Comment 11 Andre Miranda editbugs 2018-09-02 18:46:38 CEST
I see, distributions should provide a script located at /usr/libexec/gst-install-plugins-helper or /usr/lib/gst-install-plugins-helper (prefix=/usr).

To whoever is interested, all nifty details are explained here:

So I think can we close this bug, the reported problem has already been dealt, missing the install helper is another problem, in this case my distribution (Arch) does not provide it.
Comment 12 Sean Davis editbugs 2019-01-20 22:13:08 CET
Closing this bug per Andre's suggestion.

Bug #14529

Reported by:
Reported on: 2018-07-09
Last modified on: 2019-01-20
Duplicates (1):


Simon Steinbeiss
CC List:
5 users




error (107.04 KB, image/png)
2018-07-09 18:52 CEST , srkk5461
no flags
fix patch (1.82 KB, patch)
2018-08-25 23:08 CEST , Andre Miranda
no flags

Additional information